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UNIT I 

COMPUTER APPLICATIONS 

Introduction of Computer: 

 

 

 

 

 

Computer is an electronic device that operates (works) under the control of 

programs stored in its own memory unit. 

A Computer is an electronic machine that processes raw data to give information as 

output. An electronic device that accepts data as input, and transforms it under the influence 

of a set of special instructions called Programs, to produce the desired output (referred to 

as Information). 

Meaning 

 A Computer is an electronic machine that processes raw data to give information as 

output. An electronic device that accepts data as input, and transforms it under the influence 

of a set of special instructions called Programs, to produce the desired output (referred to 

as Information). 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education             Page | 2       
   

Explanations: 

A computer is described as an electronic device because; it is made up of electronic 

components and uses electric energy (such as electricity) to operate. 

 A computer has an internal memory, which stores data & instructions temporarily 

awaiting processing, and even holds the intermediate result (information) before it 

is communicated to the recipients through the Output devices. 

 It works on the data using the instructions issued, means that, the computer cannot 

do any useful job on its own. It can only work as per the set of instructions issued. 

 A computer will accept data in one form and produce it in another form. The data is 

normally held within the computer as it is being processed. 

Program: 

A computer Program is a set of related instructions written in the language of the 

computer & is used to make the computer perform a specific task (or, to direct the computer 

on what to do). 

A set of related instructions which specify how the data is to be processed. 

A set of instructions used to guide a computer through a process. 

Data: Is a collection of raw facts, figures or instructions that do not have much meaning 

to the user. 

 Data may be in form of numbers, alphabets/letters or symbols, and can be processed to 

produce information. 
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TYPES OF DATA. 

There are two types/forms of data: 

a). Digital (discrete) data: 

Digital data is discrete in nature. It must be represented in form of numbers, 

alphabets or symbols for it to be processed by a computer. Digital data is obtained by 

counting. E.g. 1, 2, 3 … 

b). Analogue (continuous) data: 

Analogue data is continuous in nature. It must be represented in physical nature in 

order to be processed by the computer.  Analogue data is obtained by measurement. E.g. 

Pressure, Temperature, Humidity, Lengths or currents, etc. The output is in form of 

smooth graphs from which the data can be read. 

Data Processing: 

It is the process of collecting all items of data together & converting them into 

information. 

Processing refers to the way the data is manipulated (or handled) to turn it into 

information. The processing may involve calculation, comparison or any other logic to 

produce the required result. The processing of the data usually results in some meaningful 

information being produced. 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education             Page | 4       
   

Information: is the data which has been refined, summarized & manipulated in the way 

you want it, or into a more meaningful form for decision-making.  The information must 

be accurate, timely, complete and relevant. 

ELEMENTS OF A COMPUTER SYSTEM: 

A Computer system is a set of six elements viz.: 

(i) Hardware, 

(ii) Software, 

(iii) People, 

(iv) Procedures, 

(v) Data and 

(vi) Connectivity. 

(i) Hardware: 

The Physical components of a computer constitute its Hardware. These include 

keyboard, mouse, monitor and processor. Hardware consists of input devices and output 

devices that make a complete computer system. 

Examples of input devices are keyboard, optical scanner, mouse and joystick which 

are used to feed data into the computer. Output devices such as monitor and printer are 

media to get the output from the computer. 
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(ii) Software: 

A Set of programs that form an interface between the hardware and the user of a 

computer system are referred to as Software. 

They are of six types: 

(a) System software: 

A Set of programs to control the internal operations such as reading data from input 

devices, giving results to output devices and ensuring proper functioning of components is 

called system software. 

(b) Application software: 

Programs designed by the user to perform a specific function, such as accounting 

software, payroll software etc. 

(c) Operating system: 

A Set of tools and programs to manage the overall working of a computer using a 

defined set of hardware components is called an operating system. It is the interface 

between the user and the computer system. 

(d) Utility software: 

Certain special purpose programs that are designed to perform a specialized task, 

such as functions to copy, cut or paste files in a computer, formatting a disk etc. 
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(e) Language processors: 

Special software to accept data and interpret it in the form of Machine /Assembly 

language understandable by a computer. It also ensures the correctness of language syntax 

and errors. 

(f) Connectivity software: 

A Set of programs and instructions to connect the computer with the main server to 

enable sharing of resources and information with the server and other connected 

computers. 

(iii) People: 

The most important element of a computer system is its users. They are also called 

live-ware of the computer system. 

The following types of people interact with a computer system: 

(a) System Analysts: 

People who design the operation and processing of the system. 

(b) System Programmers: 

People who write codes and programs to implement the working of the system 

(c) System Operators: 

People who operate the system and use it for different purposes. Also called the end 

users. 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education             Page | 7       
   

(iv) Procedures: 

Procedure is a step by step series of instructions to perform a specific function and 

achieve desired output. 

In a computer system, there are three types of procedures: 

(a) Hardware oriented procedure: 

It defines the working of a hardware component. 

(b) Software oriented procedure: 

It is a set of detailed instructions for using the software. 

(c) Internal procedure: 

It maintains the overall internal working of each part of a computer system by 

directing the flow of information. 

(v) Data: 

The facts and figures that are fed into a computer for further processing are called 

data. Data is raw until the computer system interprets it using machine language, stores it 

in memory, classifies it for processing and produces results in conformance with the 

instructions given to it. Processed and useful data is called information which is used for 

decision making. 
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(vi) Connectivity: 

When two or more computers are connected to each other, they can share 

information and resources such as sharing of files (data/music etc.), sharing of printer, 

sharing of facilities like the internet etc. This sharing is possible using wires, cables, 

satellite, infra-red, Bluetooth, microwave transmission etc. 

COMPONENTS OF A COMPUTER SYSTEM: 

A Computer system mainly has three components viz. Input Unit, Central 

Processing Unit and Output Unit. These components are the building blocks of a computer 

and define its architecture. 

The relationship among these components is well established by the following 

diagram: 

 

(i) Input Unit: 

Input unit is responsible for controlling the various input devices that are used to 

enter data into the computer. The commonly used input devices are mouse, keyboard, light 

pen, optical scanner etc. While some input devices are designed for special purposes such 

as Optical Character Recognition (OCR), Magnetic Ink Character Recognition (MICR) and 

https://www.yourarticlelibrary.com/wp-content/uploads/2015/07/clip_image00277.jpg


    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education             Page | 9       
   

Bar Code Reader etc, there are other devices that accept input by responding to physical 

touch and voice such as ATMs. 

 

 

(ii) Central Processing Unit (CPU): 

The CPU ensures the flow of data into the system by directing the data to enter the 

system, storing it into the memory and retrieving it when needed to produce the output. 

https://www.yourarticlelibrary.com/wp-content/uploads/2015/07/clip_image00463.jpg
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It has three parts: 

(a) Arithmetic and Logic Unit (ALU): 

It performs all the arithmetical calculations and computations like addition, 

subtraction, multiplication and division. It is also responsible for logical calculations like 

comparisons among data items. 

(b) Memory Unit: 

The data has to be stored in the memory blocks of the computer before it is retrieved 

for actual processing. 

(c) Control Unit: 

As the name suggests, control unit controls and coordinates the activities of all the 

components of the computer system. It reads data from the memory, decodes the 

instructions, looks after its execution, and fetches the next instruction and so on. 

(iii) Output Unit: 

It controls various output devices like printer, graphic plotter, speech synthesizer, 

monitor (also known as Visual Display Unit or VDU) to produce the desired output and 

present it to the user. It ensures the convertibility of output into human readable form that 

is understandable by the user. 
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PARTS OF A COMPUTER SYSTEM 

Here are the 12 Main Parts of a Desktop PC Computer 

Several years ago, I used to build custom computers as a hobby. I would order 

separate computer parts and connect them together on a PC motherboard inside a computer 

case to assemble a custom PC. 

rom that hobby I learned so much about computer parts, and it was so exciting to 

plan, design, find the best parts (that should be compatible between them) and finally 

assemble a custom-built computer machine. 

As you will see below, Desktop computers are made up of a lot of different parts 

that work together to perform for you. 

https://www.yourarticlelibrary.com/wp-content/uploads/2015/07/clip_image00653.jpg
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What I will try to do in this article is to teach you some basic functions of the main 

computer parts so when you open a computer up, you can identify these different parts and 

know what they do. 

Let’s take a look at the main components of a desktop computer below: 

 Motherboard 

 CPU 

 RAM 

 GPU (Video Card) 

 Storage (Mechanical Hard Disk or SSD) 

 Power Supply 

 Computer Monitor 

 Keyboard 

 Mouse 

 Optical Drive (DVD/CD ROM) 

 Network Interface Card or WiFi Card 

 Desktop Case 

 

Motherboard 

The motherboard is the main circuit board inside your computer. It is the “common 

ground” that allows all of the other components to communicate with one another. 

https://www.tech21century.com/main-parts-of-a-desktop-computer/#Motherboard
https://www.tech21century.com/main-parts-of-a-desktop-computer/#CPU
https://www.tech21century.com/main-parts-of-a-desktop-computer/#RAM
https://www.tech21century.com/main-parts-of-a-desktop-computer/#GPU_Video_Card
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Storage_Mechanical_Hard_Disk_or_SSD
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Power_Supply
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Computer_Monitor
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Keyboard
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Mouse
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Optical_Drive_DVDCD_ROM
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Network_Interface_Card_or_WiFi_Card
https://www.tech21century.com/main-parts-of-a-desktop-computer/#Desktop_Case
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A number of other parts are attached to the motherboard, such as the memory RAM 

chips, the ROM, the CPU, PCI slots, USB ports etc, and it has controllers for your hard 

drive, DVD drive, keyboard, mouse etc. 

The motherboard is the part that connects everything so that your computer can run. 

It has empty slots on which you can connect additional components if needed (e.g extra 

RAM, separate Graphics Card, additional disk storage etc). 

CPU 

The CPU is the central processing unit of the computer. It is considered the “brain” 

of the computer and is the part that processes all of the instructions. 
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It runs the operating system, and it receives input and instructions from software 

and the other hardware. 

Then it processes the input data and creates output which is either displayed on the 

screen or send to other components such as the Storage devices, printers etc. 

The CPU has a chip inside that is where this activity takes place. The CPU’s main 

performance metric is the Frequency (GHz) that is “clocked”, which means how fast the 

CPU runs. 

Some people tend to “overclock” their CPU, which means that they force the CPU 

to work at higher speeds from its designated value. In such cases, you must use a CPU 

Temperature Monitor software to make sure you don’t burn the CPU. 

https://www.tech21century.com/best-cpu-temperature-monitor/
https://www.tech21century.com/best-cpu-temperature-monitor/
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RAM 

RAM stands for random access memory. It is hardware that is found in many 

different electronic devices, including a computer. 

 

 

The amount of RAM in the computer determines how much memory applications 

that are open can use. 

If a computer has more RAM, the user can open more programs without the speed 

slowing down. 

Each program runs inside RAM which is a very high-speed memory area, so the 

program runs faster inside RAM. When you switch off the computer, all data in RAM is 

erased. 

RAM is in the form of “chip modules” as shown on the picture above. Usually we 

have 2-4 RAM chip modules which are inserted in slots on the motherboard. 
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For example, if you have 2x4GB RAM modules, your computer will have a total of 8 GB 

RAM. 

GPU (Video Card) 

GPU stands for graphics processing unit. It is a processor that handles graphics 

operations, including 2D and 3D calculations, and it excels at 3D graphics. 

 

This is an important component for gaming because the GPU can render graphics 

more efficiently than the CPU can. 

For lower-end computers, the GPU is embedded on the motherboard. For high-end 

computers or for gaming desktop PCs, the GPU comes as a separate “Video Card” which 

is inserted in a motherboard slot (as shown on the picture above). 
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Storage (Mechanical Hard Disk or SSD) 

The storage device, or hard disk, is the hardware that stores data which is not erased when 

you power-off the computer. 

 

It stores the operating system, applications, files, and folders for the user. People 

often are referring to the storage when they talk about how much memory a computer has. 

This is the capacity of the hard disk to store files. 

In previous years, the most common type of storage was the mechanical Hard Disk 

(see picture above). 

Nowadays, almost all computers come with SSD disk (Solid State Drive) which is 

a much faster disk compared to a mechanical hard disk. 

https://www.tech21century.com/different-types-of-storage-devices/
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Power Supply 

 

The power supply is the component that supplies power to the whole Desktop 

computer system. It plugs in and receives power from an electrical outlet. It then converts 

the current from an alternating current (AC) to a direct current (DC). 

It regulates current and smooths-out any spikes in voltage which enters the computer 

at any given time and prevents damage to the sensitive electronic components. 

Computer Monitor 

The computer monitor is also called the screen or display. It shows the user the 

output and allows the user to see the information being processed on the computer. 

Most monitors today use LED technology, and they are flat screens that take up less 

space than the old CRT displays. 

https://www.tech21century.com/different-types-of-computer-monitors/
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Keyboard 

The keyboard is the main “input” device (together with the mouse) of any computer. 

It is one of the main devices used for communicating with the rest of the world (e.g 

typing emails, searching the Internet etc) and its design mimics the old typewriter 

keyboards. 

It is called the QWERTY layout. It gets its name from the first six letters on the top 

left corner of the keyboard. There are additional function keys and shortcut keys that vary 

on different keyboards. 

Like almost every computer component, there are various types of computer 

keyboards such as mechanical, ergonomic, membrane, with backlight etc. 

Mouse 

The mouse is another important input device. It is named because the shape of the 

mouse resembles the shape of the animal, and the cord represents the tail. 

However, most mouses are wireless today. You can refer to the plural as mouses or 

mice, although mouses is the technically correct term. 

They usually have two buttons and can have more. You can scroll up and down on 

a scroll wheel if the mouse has one. The mouse moves an arrow that allows you to open 

applications. 

https://www.tech21century.com/different-types-of-computer-keyboards/
https://www.tech21century.com/different-types-of-computer-keyboards/
https://www.tech21century.com/types-of-computer-mouse/
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Optical Drive (DVD/CD ROM) 

The optical drive uses a laser that writes and reads data on optical discs, such as a 

DVD or CD. 

 

They are made up of millions of small dips and bumps, and the optical drive reads 

them as zeros and ones. 

The optical drive can read and write data on these discs. When the laser writes data 

onto the disc, it burns it in. For this reason, people “burn” CDs. 

Network Interface Card or WiFi Card 

The network interface card is also called the NIC (pronounced Nick). This part is 

what gives a computer its networking capabilities. 
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It can allow a wired Ethernet connection or a wireless WiFi connection to a LAN (local 

area network). Today, most computers have wireless NICs that are designed for WiFi 

connection. Also, you can insert a wired Ethernet NIC card in a motherboard slot to get 

additional network connectivity ports if needed. 

Desktop Case 

The desktop case is the mount that houses all of the components of the computer, 

including the motherboard, the hard drive, the optical drive, and more. 
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Many of them are made of metal, and they are important because they protect the 

computer components from damage due to dust, accidents, liquids, and more. 

It also helps to keep the components cool enough and usually has airflow through 

vents to make sure that the computer doesn’t overheat. Finally, it helps to cut down on the 

noise made by computer parts.  

Basic Applications of Computer 

Computers play a role in every field of life. They are used in homes, business, 

educational institutions, research organizations, medical field, government offices, 

entertainment, etc. 
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Home 

Computers are used at homes for several purposes like online bill payment, 

watching movies or shows at home, home tutoring, social media access, playing games, 

internet access, etc. They provide communication through electronic mail. They help to 

avail work from home facility for corporate employees. Computers help the student 

community to avail online educational support. 

Medical Field 

Computers are used in hospitals to maintain a database of patients’ history, 

diagnosis, X-rays, live monitoring of patients, etc. Surgeons nowadays use robotic surgical 

devices to perform delicate operations, and conduct surgeries remotely. Virtual reality 

technologies are also used for training purposes. It also helps to monitor the fetus inside 

the mother’s womb. 

Entertainment 

Computers help to watch movies online, play games online; act as a virtual 

entertainer in playing games, listening to music, etc. MIDI instruments greatly help people 

in the entertainment industry in recording music with artificial instruments. Videos can be 

fed from computers to full screen televisions. Photo editors are available with fabulous 

features. 

Industry 

Computers are used to perform several tasks in industries like managing inventory, 

designing purpose, creating virtual sample products, interior designing, video 

conferencing, etc. Online marketing has seen a great revolution in its ability to sell various 
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products to inaccessible corners like interior or rural areas. Stock markets have seen 

phenomenal participation from different levels of people through the use of computers. 

Education 

Computers are used in education sector through online classes, online examinations, 

referring e-books, online tutoring, etc. They help in increased use of audio-visual aids in 

the education field. 

Government 

In government sectors, computers are used in data processing, maintaining a 

database of citizens and supporting a paperless environment. The country’s defense 

organizations have greatly benefitted from computers in their use for missile development, 

satellites, rocket launches, etc. 

Banking 

In the banking sector, computers are used to store details of customers and conduct 

transactions, such as withdrawal and deposit of money through ATMs. Banks have reduced 

manual errors and expenses to a great extent through extensive use of computers. 

Business 

Nowadays, computers are totally integrated into business. The main objective of 

business is transaction processing, which involves transactions with suppliers, employees 

or customers. Computers can make these transactions easy and accurate. People can 

analyze investments, sales, expenses, markets and other aspects of business using 

computers. 
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Training 

Many organizations use computer-based training to train their employees, to save 

money and improve performance. Video conferencing through computers allows saving of 

time and travelling costs by being able to connect people in various locations. 

Arts 

Computers are extensively used in dance, photography, arts and culture. The fluid 

movement of dance can be shown live via animation. Photos can be digitized using 

computers. 

Science and Engineering 

Computers with high performance are used to stimulate dynamic process in Science 

and Engineering. Supercomputers have numerous applications in area of Research and 

Development (R&D). Topographic images can be created through computers. Scientists 

use computers to plot and analyze data to have a better understanding of earthquakes. 

Types of another Computer applications 

   Most of the beginners confused about types of Computer Applications and It 

is not easy to divide computer applications into any exact categories. At present there is no 

clear definition available to categorize computer applications. Even though here is a small 

list of different types of computer applications. 

1. Embedded Systems 

2. Windows applications (also called 'Desktop applications') 

3. Web Applications 

4. Web Services 
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5. Console applications  

Embedded Systems 

When we save a name, address and other information in to our Mobile Phone or 

Digital Diary, You know How it gets saved in it? Nothing but which is a small computer 

program 'Embedded' into a chip in the device inside the mobile phone or digital diary 

known as Embedded Systems. 

Windows applications 

Windows Applications is a form based standard Windows, Microsoft word; Paint is 

example to the Windows application, and also called 'Desktop applications'. 

Web Applications 

A web site is also called 'web Applications'. A web applications is a collection of 

web pages hosted on a special computer called 'web server'. Web server can be located 

anywhere and visitors can be located anywhere .It will work through Browsers (EG. 

Internet Explorer, Mozilla, Netscape). 

Web Services 

Web services are web applications that give services to other applications through 

the internet, example Google search engine, Yahoo Search engine etc. which allows other 

applications to delegate the task of searching over the internet. 

Console Applications 

Console applications runs inside the command prompt i.e. DOS window, It is a light 

weight program and which is used commonly for test applications.  
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COMPUTER 

A Computer is an electronic device that accepts data from the user, processes it, 

produces results, displays them to the users, and stores the results for future usage. 

Data is a collection of unorganized facts & figures and does not provide any further 

information regarding patterns, context, etc. Hence data means "unstructured facts and 

figures". 

Information is a structured data i.e. organized meaningful and processed data. To 

process the data and convert into information, a computer is used. 

FUNCTIONS OF COMPUTERS 

A Computer performs the following functions − 

Receiving Input 

Data is fed into computer through various input devices like keyboard, mouse, 

digital pens, etc. Input can also be fed through devices like CD-ROM, pen drive, scanner, 

etc. 

Processing the information 

Operations on the input data are carried out based on the instructions provided in 

the programs. 

Storing the information 

After processing, the information gets stored in the primary or secondary storage 

area. 

Producing output 
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The processed information and other details are communicated to the outside world 

through output devices like monitor, printer, etc. 

COMPUTER CONCEPTS - HISTORY OF COMPUTERS 

The history of the computer dates back to several years. There are five prominent 

generations of computers. Each generation has witnessed several technological advances 

which change the functionality of the computers. This results in more compact, powerful, 

robust systems which are less expensive. The brief history of computers is discussed below:  

First Generation (1940-1956) 

The first generation computers had the following features and components − 

Hardware 

The hardware used in the first generation of computers was: Vacuum Tubes and Punch 

Cards. 

Features 

Following are the features of first generation computers − 

 It supported machine language. 

 It had slow performance 

 It occupied large size due to the use of vacuum tubes. 

 It had a poor storage capacity. 

 It consumed a lot of electricity and generated a lot of heat. 

Memory 

The memory was of 4000 bits. 
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Data Input 

The input was only provided through hard-wired programs in the computer, mostly 

through punched cards and paper tapes. 

Examples 

The examples of first generation computers are − 

 ENIAC 

 UNIVACTBM 701 

Second Generation (1956-1963) 

Several advancements in the first-gen computers led to the development of second 

generation computers. Following are various changes in features and components of 

second generation computers − 

Hardware 

The hardware used in the second generation of computers were − 

 Transistors 

 Magnetic Tapes 

Features 

It had features like − 

 Batch operating system 

 Faster and smaller in size 

 Reliable and energy efficient than the previous generation 
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 Less costly than the previous generation 

Memory 

The capacity of the memory was 32,000 bits. 

Data Input 

The input was provided through punched cards. 

Examples 

The examples of second generation computers are − 

 Honeywell 400 

 CDC 1604 

 IBM 7030 

Third Generation (1964-1971) 

Following are the various components and features of the third generation 

computers − 

Hardware 

The hardware used in the third generation of computers were − 

 Integrated Circuits made from semi-conductor materials 

 Large capacity disks and magnetic tapes 

Features 

The features of the third generation computers are − 

 Supports time-sharing OS 
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 Faster, smaller, more reliable and cheaper than the previous generations 

 Easy to access 

Memory 

The capacity of the memory was 128,000 bits. 

Data Input 

The input was provided through keyboards and monitors. 

Examples 

The examples of third generation computers are − 

 IBM 360/370 

 CDC 6600 

 PDP 8/11 

Fourth Generation (1972-2010) 

Fourth generation computers have the following components and features − 

Hardware 

The Hardware used in the fourth generation of computers were − 

 ICs with Very Large Scale Integration (VLSI) technology 

 Semiconductor memory 

 Magnetic tapes and Floppy 

Features 

It supports features like − 
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 Multiprocessing & distributed OS 

 Object-oriented high level programs supported 

 Small & easy to use; hand-held computers have evolved 

 No external cooling required & affordable 

 This generation saw the development of networks and the internet 

 It saw the development of new trends in GUIs and mouse 

Memory 

The capacity of the memory was 100 million bits. 

Data Input 

The input was provided through improved hand held devices, keyboard and mouse. 

Examples 

The examples of fourth generation computers are − 

 Apple II 

 VAX 9000 

 CRAY 1 (super computers) 

Fifth Generation (2010-Present) 

These are the modern and advanced computers. Significant changes in the 

components and operations have made fifth generation computers handy and more reliable 

than the previous generations. 
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Hardware 

The Hardware used in the fifth generation of computers are − 

 Integrated Circuits with VLSI and Nano technology 

 Large capacity hard disk with RAID support 

 Powerful servers, Internet, Cluster computing 

Features 

It supports features like − 

 Powerful, cheap, reliable and easy to use. 

 Portable and faster due to use of parallel processors and Super Large Scale Integrated 

Circuits. 

 Rapid software development is possible. 

Memory 

The capacity of the memory is unlimited. 

Data Input 

The input is provided through CDROM, Optical Disk and other touch and voice 

sensitive input devices. 

Examples 

The examples of fifth generation computers are − 

 IBM 

 Pentium 
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 PARAM 

COMPUTER CONCEPTS - PROGRAMMING LANGUAGES 

A Program is a set of instructions that help computer to perform tasks. This set of 

instructions is also called as scripts. Programs are executed by processor whereas scripts 

are interpreted. The languages that are used to write a program or set of instructions are 

called "Programming languages". Programming languages are broadly categorized into 

three types − 

 Machine level language 

 Assembly level language 

 High-level language 

Machine Level Language 

Machine language is lowest level of programming language. It handles binary data 

i.e. 0’s and 1’s. It directly interacts with system. Machine language is difficult for human 

beings to understand as it comprises combination of 0’s and 1’s. There is software which 

translate programs into machine level language. Examples include operating systems like 

Linux, UNIX, Windows, etc. In this language, there is no need of compilers and interpreters 

for conversion and hence the time consumption is less. However, it is not portable and non-

readable to humans. 
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Assembly Level Language 

Assembly language is a middle-level language. It consists of a set of instructions in 

a specific format called commands. It uses symbols to represent field of instructions. It is 

very close to machine level language. The computer should have assembler to translate 

assembly level program to machine level program. Examples include ADA, PASCAL, etc. 

It is in human-readable format and takes lesser time to write a program and debug it. 

However, it is a machine dependent language. 

Assembly Language Machine Code 

SUB AX, BX 0010101110000011 

MOV CX, AX 100010111001000 

MOV DX, 0 10111010000000000000000 
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High-level Language 

High-level language uses format or language that is most familiar to users. The 

instructions in this language are called codes or scripts. The computer needs a compiler 

and interpreter to convert high-level language program to machine level language. 

Examples include C++, Python, Java, etc. It is easy to write a program using high level 

language and is less time-consuming. Debugging is also easy and is a human-readable 

language. Main disadvantages of this are that it takes lot of time for execution and occupies 

more space when compared to Assembly- or Machine-level languages. Following is a 

simple example for a high level language – 

 

if age < 18 { 

   printf("You are not eligible to vote"); 

} else{ 

   printf("You are eligible to vote"); 

} 

 

Representation of Data/Information 

Computer does not understand human language. Any data, viz., letters, symbols, 

pictures, audio, videos, etc., fed to computer should be converted to machine language first. 

Computers represent data in the following three forms − 
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Number System 

We are introduced to concept of numbers from a very early age. To a computer, everything 

is a number, i.e., alphabets, pictures, sounds, etc., are numbers. Number system is 

categorized into four types − 

 Binary number system consists of only two values, either 0 or 1 

 Octal number system represents values in 8 digits. 

 Decimal number system represents values in 10 digits. 

 Hexadecimal number system represents values in 16 digits. 

 

 

Number System 

System Base Digits 

Binary 2 0 1 

Octal 8 0 1 2 3 4 5 6 7 

Decimal 10 0 1 2 3 4 5 6 7 8 9 

Hexadecimal 16 0 1 2 3 4 5 6 7 8 9 A B C D E F 
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Bits and Bytes 

Bits − A bit is a smallest possible unit of data that a computer can recognize or use. 

Computer usually uses bits in groups. 

Bytes − group of eight bits is called a byte. Half a byte is called a nibble. 

 

The following table shows conversion of Bits and Bytes – 

Byte Value Bit Value 

1 Byte 8 Bits 

1024 Bytes 1 Kilobyte 

1024 Kilobytes 1 Megabyte 

1024 Megabytes 1 Gigabyte 

1024 Gigabytes 1 Terabyte 
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1024 Terabytes 1 Petabyte 

1024 Petabytes 1 Exabyte 

1024 Exabytes 1 Zettabyte 

1024 Zettabytes 1 Yottabyte 

1024 Yottabytes 1 Brontobyte 

1024 Brontobytes 1 Geopbytes 

Text Code 

Text code is format used commonly to represent alphabets, punctuation marks and 

other symbols. Four most popular text code systems are − 

 EBCDIC 

 ASCII 

 Extended ASCII 

 Unicode 

EBCDIC 

Extended Binary Coded Decimal Interchange Code is an 8-bit code that defines 256 

symbols. Given below is the EBCDIC Tabular column 
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ASCII 

American Standard Code for Information Interchange is an 8-bit code that specifies 

character values from 0 to 127. 

ASCII Tabular column 

ASCII Code Decimal Value Character 

0000 0000 0 Null prompt 

0000 0001 1 Start of heading 
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0000 0010 2 Start of text 

0000 0011 3 End of text 

0000 0100 4 End of transmit 

0000 0101 5 Enquiry 

0000 0110 6 Acknowledge 

0000 0111 7 Audible bell 

0000 1000 8 Backspace 

0000 1001 9 Horizontal tab 

0000 1010 10 Line Feed 

Extended ASCII 

Extended American Standard Code for Information Interchange is an 8-bit code that 

specifies character values from 128 to 255. 

Extended ASCII Tabular column 
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Unicode 

Unicode Worldwide Character Standard uses 4 to 32 bits to represent letters, 

numbers and symbol. 

Unicode Tabular Column 

 

Data Processing & Data Processing Stages 

Data processing 

Data processing is a process of converting raw facts or data into a meaningful 

information. 
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STAGES OF DATA PROCESSING 

Data processing consists of following 6 stages − 

 

Collection 

Collection of data refers to gathering of data. The data gathered should be defined 

and accurate. 

Preparation 

Preparation is a process of constructing a dataset of data from different sources for 

future use in processing step of cycle. 
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Input 

Input refers to supply of data for processing. It can be fed into computer through 

any of input devices like keyboard, scanner, mouse, etc. 

Processing 

The process refers to concept of an actual execution of instructions. In this stage, 

raw facts or data is converted to meaningful information. 

Output and Interpretation 

In this process, output will be displayed to user in form of text, audio, video, etc. 

Interpretation of output provides meaningful information to user. 

Storage 

In this process, we can store data, instruction and information in permanent memory 

for future reference. 

TYPES OF APPLICATION SOFTWARE 

Knowing ‘what is an application software’ and the 'types of 

application software ' helps you take the most business-beneficial decisions. If you want 

to dig into the real meaning of the term software application, you need to explore and 

recognize different categories of application software. 

This blog is an attempt to enlighten you about the following topics: 

 An overview of different terms related to software 
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 What is application software? 

 Different types of software applications  

 Business Application Software 

 Benefits of Application Software for Businesses 

 How to Choose an Application Software for your Business 

Application software and software application and app are terms that are often used 

interchangeably in the custom software development landscape.  

Types of Applications Software: An Overview with Different Terms Related to 

Software 

Before defining ‘what is application software’, I think it’s better to micro analyze 

the terms, ‘software’ and ‘application’. 

Computer software is a phenomenal aspect that acts as the soul of the computer. 

The computer is just a set of hardware or a tangible machine without software in it. It is 

software that makes computers operational and useful. You can make your business work 

smartly by choosing the software that matches your business requirements and goals. 

It is an entire system of programs, procedures or algorithms, and other operating 

information that synchronize with the hardware to run the machine. They are designed to 

achieve the input, processing, output, storage, and control activities of information systems. 

https://www.bridge-global.com/services/custom-software-development
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Application is a type of software designed for end-users to accomplish specific 

functions. All the applications are software, but not vice versa. 

All types of computer software fall into either of the following two categories: 

 System software 

 Application software 

System software is intended to manage the system resources, whereas application 

software enables the user to perform some specific sets of functions. 

The system software also simplifies application programming. Examples of System 

Software are operating systems, firmware, database management systems, device drivers, 

networking software, assemblers, compilers, translators, and software utilities. 

APPLICATION SOFTWARE 

To quote Wikipedia, “an application program (app or application for short) is a 

computer program designed to carry out a specific task other than one relating to the 

operation of the computer itself, typically to be used by end-users.” This specific task can 

be in line with the user requirements. 

We can define application software as software that employs the capabilities of a 

computer to accomplish a dedicated task. 

The user will be interacting directly with a piece of software in the case of 

application software. IT helps them to be more productive and assists them in fulfilling 

specific personal or business tasks. 

https://en.wikipedia.org/wiki/Application_software
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Examples of application software are Microsoft Word, spreadsheets, VLC media player, 

Firefox or Google Chrome, accounting applications, photo editor, mobile apps such as 

video games, Whatsapp, etc. 

It also includes software that is internally/externally developed to fulfill the unique needs 

of an organization Application software will always be based on an operating system. 

Types of Application Software: An Extensive List for 2021  

Every sphere of businesses needs application software as digitization and use of the 

software is rampant in all domains including healthcare and pharmacy, home, education, 

industries, communication, engineering, travel & tourism, etc. Different types of 

application software are used for information management, data manipulation, visual 

construction, resource coordination, and calculations. 

A broader way to give the list of application software is as below. 

 Packaged Software 
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 Custom Software 

 Shareware 

 Freeware 

 Public domain Software 

But, in this blog, I prefer to give the application software list as an index of commonly 

used types of application software. Each of these types of software programs belongs to 

the above-listed broader types of applications as well. 

  Word processors 

 Graphics software 

 Database software 

 Spreadsheet software 

 Presentation software 

 Web browsers 

 Enterprise software 

 Information worker software 

 Multimedia software 
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 Content access software 

The list of application software can be an exhaustive one. Let me attempt to elucidate a 

few of the application software from this list. 

1. Presentation Software 

Presentation software is a very commonly used type of application software both 

for personal and business purposes. These programs are specifically designed to help users 

to present information, thoughts, and ideas with ease and clarity through engaging visual 

modes such as text, pictures, sound, and video. 

The three key elements of presentation software are: 

 Text editor to enter and stylize texts 

 Enabler to insert graphics, text, video, and multimedia files 

 Slideshow facility to display the content 

Microsoft’s PowerPoint is the chief example of application software in the presentation 

software category. It helps you exhibit information in the form of slides. 

You can insert text, images, graphs, and videos to make these slides attractive and 

engrossing. 

Google Slides and Apple’s Keynote are other capable alternatives.  

https://en.wikipedia.org/wiki/Presentation_program
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2. Spreadsheet Software 

Spreadsheet application software helps in organizing, storing, and analyzing data in 

columns and rows to facilitate calculations effortlessly and efficiently. 

These rows and columns can be operated through formulas to execute crucial mathematical 

functions. This is a digital simulation of traditional physical (paper) worksheets. Examples 

of application software in the Spreadsheet category are Microsoft Excel, Google Sheets, 

and Apple Numbers. 

3. Database Software 

Database application software, also known as a DBMS (Database Management 

System), is a collection of data associated with any application. 

This helps in organizing data by creating and managing a database by storing, modifying, 

extracting, and searching for information within a database. 

When we run an application, it accesses the data from the database and stores it after 

modifications. Examples of database application software are MS Access, Oracle, MySQL, 

Microsoft SQL Server, PostgreSQL, MongoDB, IBM Db2, etc. 

4. Multimedia Software 

Multimedia application software helps users to create, edit, or record images, audio, 

and video files. This type of application software is a dominant player in the entertainment, 

media, and telecommunication industry. 

https://en.wikipedia.org/wiki/Spreadsheet
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They are designed to enhance the visual and auditory features of the already present 

material. They combine together text, audio, still images, animation, video, and 

interactivity to communicate and engage better. VLC media player and Windows Media 

Player are a few examples. 

5. Simulation Software 

Simulation application software is developed by modeling a real phenomenon with 

a set of mathematical prescriptions. Simulation software is designed as an animated model 

that replicates the operation of an existing/proposed system. 

They are helpful in military engineering, gaming, industries such as power plants, space 

shuttle navigation, etc. where improper operation can lead to catastrophic outcomes. 

This application software helps in observing and analyzing an operation through simulation 

without actually doing it. 

6. Word Processing Software 

Word processing application software helps users to input, edit, format, and output 

text content. This type of software program processes words with pages and paragraphs 

and formats and enhances the text. It also enriches the ‘wording’ experience by helping 

users with easy access to thesaurus, synonyms, and antonyms. 

It helps in embellishing letters with art features such as font styles, colors, and styles. 

Leading examples of application software belonging to the word processing category are: 
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Google Docs, Microsoft Word Docs, Open Office Writer, Word Perfect, Wordpad, 

Notepad, AppleWorks, etc. 

7. Web Browsers 

Web browsers or simply browsers are application software used to access and view 

websites through accessing the internet/ the World Wide Web. 

It retrieves the necessary content from a web server and then shows the page on the user's 

device upon user requests. The most popular web browsers are Google Chrome, Internet 

Explorer (now Microsoft Edge), Firefox, MS Edge, Safari, etc. Web browsers or simply 

browsers are application software used to access and view websites through accessing the 

internet/ the World Wide Web. 

8. Top Business Application Software 

Business application software are types of application software categorized on the 

basis of specific business needs they meet. 

These are computer applications that are developed and designed to fulfill certain business 

functions and to enhance the accuracy, efficiency, and effectiveness of operations. 

The end result is presumed to be boosted productivity and profitability. 

1. Enterprise Resource Planning (ERP) Application Software 

Enterprise Resource Planning (ERP) is a type of application software that helps 

organizations to manage everyday business activities. 

https://brave.com/learn/most-secure-browser/
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It may cover accounting, procurement, project management, risk management and 

compliance, manufacturing, supply chain operations, and so on. 

Many businesses find it difficult to keep up with a multitude of business processes leading 

to incongruent information and workflow bottlenecks. 

An ERP software aids enterprises to plan, budget, predict and report on financial results by 

acting as a single repository for information. 

They are helpful in cost reduction and operation standardizing. Odoo, Microsoft Dynamics, 

Oracle e-Business Suite, etc. are some examples. 

 2. Customer Relationship Management Application Software 

Customer Relationship Management (CRM) is a type of application software that 

helps businesses/organizations to smartly administer their interactions with customers 

backed by data analysis. 

They help you in offering a seamless experience to your customers by forming better 

relationships. It offers truthful insights on customer interactions by overseeing your sales. 

It helps in coordinating customer information spread across different channels and 

touchpoints. 

Salesforce Sales Cloud, NetSuite CRM, Zoho CRM, etc. are a few examples of popular 

CRM application software. 

https://www.bridge-global.com/services/custom-software-development/erp-crm
https://www.bridge-global.com/services/custom-software-development/erp-crm
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3. Project Management Application Software 

“Project management software has the capacity to help plan, organize, and manage 

resource tools and develop resource estimates”, as quoted by Wikipedia. 

This type of application software is a versatile tool that lets project managers (PMs), 

stakeholders, and users regulate expenses and handle costing. 

It also helps with quality management and documentation and may also serve as an 

administration system. It also acts as a smart channel that facilitates collaboration and 

communication between project stakeholders. Jira, Zoho Projects, Basecamp, Trello, erc. 

Are some of the popular project management application software.  

4. Business Process Management (BPM) Application Software 

Business process management (BPM) software are designed to enable a methodical 

style to optimize business processes. It models, defines, automates, and describes the 

workflow process with the ultimate intention of optimizing businesses to deliver their 

goals. 

They are great tools to curtail errors, inadequacies, and miscommunication. It sheds 

complete visibility into operations. Some examples of application software of BPM are 

Zoho Creator, Kissflow, Nintex, ProcessMaker 

https://www.bridge-global.com/blog/4-popular-tools-for-agile-project-management/
https://en.wikipedia.org/wiki/Project_management_software
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5. Productivity Software 

Productivity application software are tools that aid users to accomplish their tasks 

in a productive and timely manner. These programs give a smart way for users to produce 

documents, databases, worksheets, graphs, and presentations. 

All types of application software that helps in time tracking, database management, 

project management, content management, etc. are productivity software. 

A simple categorization is to include word processing, spreadsheets, data 

management, and presentation software as productivity application software. 

6. Resource Management Application Software 

Resource management software or resource planning software is a type of 

application software that makes it easier to allocate and assign people to projects as per the 

requirements. 

It smoothens the management of multiple projects and resources. IT ensures that 

everything is distributed smartly in real-time. Mavenlink, monday.com, Forecast, etc. are 

some of the well-known resource management soft that helps you manage the human 

capital and calendar of your organization. 

7. Time Management Application Software 

Time management software helps your human resources to stay super productive 

by helping them manage their time effectively. It helps in tracking the usage of digital 

systems. It gives an outlook on how a user spends working in certain applications. 
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These tools help your team to stay more organized, and competent by getting more 

things done in a short time. Asana, Avaza, ClickTime, DeskTime, EmpMonitor, etc. are 

some examples. 

8. Educational Software 

Education software or learning management educational software are a type of 

application software that is made for educational purposes. They are designed to assist in 

the teaching and learning process of new content, concepts, and processes. They are of 

great help to administrators and educators to create content, share lessons, manage 

classrooms, and manage the institution and student-related data. 

This e-learning software offers more personalized and collaborating educational 

involvements for students and tutors alike. High interactivity level is maintained through 

the use of multimedia content, such as graphics, pictures, and sound. Google Classroom, 

Litmos, Talent LMS, ProProfs, etc. are some examples. 

BASIC FUNDAMENTAL CONCEPTS OF PROGRAMMING 

Irrespective of the programming language you choose to learn, the basic concepts of 

programming are similar across languages. Some of these concepts include: 

 Variable Declaration 

 Basic Syntax 

 Data Type and Structures 

 Flow Control Structures (Conditionals and loops) 
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 Functional Programming 

 Object-Oriented Programming 

 Debugging 

 IDEs and Coding Environments 

In the next section of this shot, you will be given a brief introduction to these concepts. 

Variable declaration 

Variables are containers for storing data values, a memory location for a data type. 

Variables are created using a declaration or keyword that varies across languages. 

Variable names are usually alphanumeric, that is, they contain a-z and 0-9. They can also 

include special characters like underscore or the dollar sign. 

Variables can hold values of any data type supported by the programming language. This 

value may change during program execution. 

Basic syntax 

Every programming language has its syntax, and you must learn the fundamental 

syntax of the language you are learning. 

Syntax refers to the set of rules that define the structure of a language. It is almost 

impossible to read or understand a programming language without its syntax. 

For example, let us declare a variable named greet and assign the value “Hello World” to 

it: 
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C++ 

JavaScript 

Java 

Python 

Data types and structures. 

Data types refer to the classification of data. The most common data types include: 

 String 

 Boolean (true or false) 

 Numbers, which includes integers (whole numbers from 1) and floating-point 

numbers (decimal-base) 

 Characters (includes single alphabets or numbers) 

 Arrays (a collection of data, usually of the same data type) 

A Data Structure is a collection of data values. These structures include operations that 

can be applied to that data. Data structures are important in computer programming for 

organizing, managing, and storing data quickly and efficiently. 

Some common types of data structures include: 

 Stacks 

 Heaps 

 Trees 

 Linked lists 
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 Queues 

 Arrays 

 Tables 

 Graphs 

Flow control structures 

Flow Control Structures are the fundamental components of computer programs. 

They are commands that allow a program to “decide” to take one direction or another. 

There are three basic types of control structures: sequential, selection, and iteration. 

Sequential 

The most basic control flow is sequential control flow. It involves the execution of 

code statements one after the other. A real-world example is following a cooking recipe. 

Selection (conditionals) 

The basic premise of selection flow control is, the computer decides what action to 

perform based on the result of a test or condition equalling true or false. 

Iteration (Loops). 

A loop is a programming structure that allows a statement or block of code to be 

run repeated until a specified condition is no longer true (will return Boolean, true or false). 

It is one of the most powerful and fundamental programming concepts. 
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Functional programming 

Functions are containers that take in a set of inputs and return an output. It is not 

required for a function to return a value. Pure functions will always give the same result 

for the same set of inputs. 

Functional Programming is a straightforward method of building software that 

involves using pure functions. This method eliminates the occurrence of data mutation or 

side effects. 

Object-oriented programming 

**Object-Oriented Programming (OOP)**is a programming concept that revolves 

around ‘objects’ and ‘methods’. 

There are four principles of OOP: 

 Inheritance 

 Polymorphism 

 Abstraction 

 Encapsulation 

Debugging 

Debugging is a crucial skill. It involves detecting and removing existing and 

potential errors, defects, or ‘loopholes’ in one’s code. 
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IDEs and Coding Environments 

IDE stands for Integrated Development Environment – they are applications 

programmers use to write code and organize text groups. It increases a programmer’s 

efficiency and productivity, and has added features like code completion, code 

compilation, debugging, syntax highlighting, etc. 

Some common examples of IDE’s are: 

 Visual Studio code 

 IntelliJ IDEA 

 NetBeans 

 Eclipse 

 

 

 

 

 

 

 

 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 62       
   

UNIT – II 

MS WORD 

AN INTRODUCTION TO MS WORD 

One of the most widely used programs of Microsoft Office suite, MS Word is a 

word processor developed by Microsoft.  

An introduction to MS Word, its features and its uses, have all been discussed in 

detail, in this article. Also, a few sample questions based on this MS Office program have 

been given further below for the reference of candidates preparing for competitive exams.  

To know further about the MS Office suite and the various programs included in it, visit 

the linked article.  

Since MS Word is one of the most used programs of the Office Suite, some basic 

information regarding its creation and development has been given below: 

 Charles Simonyi, a developer and Richard Brodie, a software engineer, were the 

two creators of MS Word 

 This program was initially named “Multi-Tool Word” but later, was renamed as MS 

Word 

 It was introduced in 1983 

 Word for Windows is available standalone or as a part of MS Office suite 

 MS Word for Mac was introduced by Microsoft as Word 1.0 in 1985 

 The extension for any word file is “.doc or .docx.” 

https://byjus.com/govt-exams/microsoft-office/
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Moving forward, details about the features and applications of Word have been discussed. 

To read more about the other Computer Knowledge topics, check the links given below: 

BASICS OF MS WORD 

Let us first understand some basic aspects of Microsoft Word. 

 

MS Word 

Used to make professional-quality documents, letters, reports, etc., MS Word is a 

word processor developed by Microsoft. It has advanced features which allow you to 

format and edit your files and documents in the best possible way.  

To find MS Word on your personal computer 

Follow these simple steps to open MS Word on your personal computer: 

Start → All Programs → MS Office → MS Word. 

Uses of MS Word 

MS Word enables users to do write-ups, create documents, resumes, contracts, etc. 

This is one of the most commonly used programs under the Office suite.  
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To Create an MS Word Document 

To create an MS Word doc, follow the steps mentioned above to open Microsoft 

Word. Then once the program is open, click on “File” followed by “New”. This opens a 

new doc where something new can be created. 

Since it is used by people of all age groups, in schools, in colleges and for official purposes, 

having proper knowledge of Microsoft Word is a must. The preview of the MS Doc file 

once it is opened is given below: 

 

Also, from a competitive exam perspective, one must be well aware of this topic. To get 

the list of all major Government exams conducted in the country, aspirants can visit the 

linked article.  

For a better understanding of how MS Word works and the features that are included in it, 

you can refer to the video given below and analyse its functioning easily. 

https://byjus.com/govt-exams/
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FEATURES OF MS WORD 

Now let us read more about the features and components of an MS Word doc file in 

detail. 

The image given below shows the different elements and categories which are available in 

MS Word doc: 

 

 Home 

This has options like font colour, font size, font style, alignment, bullets, line spacing, etc. 

All the basic elements which one may need to edit their document is available under the 

Home option. 

 Insert 

Tables, shapes, images, charts, graphs, header, footer, page number, etc. can all be entered 

in the document. They are included in the “Insert” category. 
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 Design 

The template or the design in which you want your document to be created can be selected 

under the Design tab. Choosing an appropriate tab will enhance the appearance of your 

document. 

 Page Layout 

Under the Page Layout tab comes options like margins, orientation, columns, lines, 

indentation, spacing, etc.  

 References 

This tab is the most useful for those who are creating a thesis or writing books or lengthy 

documents. Options like citation, footnote, table of contents, caption, bibliography, etc. can 

be found under this tab. 

 Review 

Spell check, grammar, Thesaurus, word count, language, translation, comments, etc. can 

all be tracked under the review tab. This acts as an advantage for those who get their 

documents reviewed on MS Word. 

Apart from all the above-mentioned features, the page can be set in different views and 

layouts, which can be added and optimised using the View tab on the Word document. 

Margins and scales are also available for the benefit of the users.  

When compared with MS PowerPoint, MS Word is more of reading while PPT is more of 

visual and graphical representation of data.  

https://byjus.com/govt-exams/microsoft-powerpoint/
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To know more about Microsoft Windows, visit the linked article. 

For Govt exam aspirants, given below are links to the other subjects which are a part of the 

competitive exam syllabus: 

USES OF MS WORD 

Given below are the different fields in which MS Word is used and simplifies the 

work of an individual: 

 In Education: It is considered as one of the simplest tools which can be used by 

both teachers and students. Creating notes is easier using MS Word as they can be 

made more interactive by adding shapes and images. It is also convenient to make 

assignments on MS Word and submitting them online 

 In Workplace: Submitting letters, bills, creating reports, letterheads, sample 

documents, can all easily be done using MS Word 

 Creating & Updating Resume: One of the best tools to create your resumes and is 

easy to edit and make changes in it as per your experience 

 For Authors: Since separate options are available for bibliography, table of 

contents, etc., it is the best tool which can be used by authors for writing books and 

adjusting it as per the layout and alignment of your choice 

https://byjus.com/govt-exams/microsoft-windows/
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FORMATTING TEXT IN MS WORD 

Students and professionals use Word for documenting their work and projects. 

Formatting can help draw the reader’s attention to a specific part of the document, and also 

emphasize on main points or the headlines of the document. You can see all the formatting 

options for Word under the Home tab. This is the default tab that is selected when you 

open a new or existing document. 

 

Let us see how we can change the formatting of text in Word. 

To Format Font Size in Word 

Formatting the font size is one of the most used cases of formatting. Follow the steps 

mentioned below to change the font size of your text. 
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1. Choose the words or text whose size you wish to change. 

 

2. From the Font Group under the Home tab, choose the necessary font size from the 

dropdown. You can also type the desired font size for your text in the space. 
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Here is another method you can follow to change the font size of your text. 

1. Select the text to change its size. 

  

2. Click on the right mouse button to open the formatting options and a menu. 
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3. You can choose the desired font size from the formatting options that appear. 

You can also change the font size of your text using the Shrink and Grow buttons. To do 

so, select the text whose size you wish to change. Click on the Shrink button to decrease 

the size, and the Grow button to increase the font size. Select the whole document to 

change the font size of the whole document. Every time you use these buttons, your font 

size changes by 1 point. 

 

 

To Format Font Style 

Formatting font style is a very easy task and can be successfully done by following the 

steps mentioned. There are two ways, and we would be discussing both of them. 

Method 1: 

1. Choose the words or text to change its style. 
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2. From the Font Group under the Home tab, choose the necessary font style from the 

dropdown menu. In case you know the specific font style that you want, you can start 

typing in the style box to get it easily. 
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Method 2: 

1. Select the text whose style has to be changed. 

  

2. Select the text and click on the right mouse button. Formatting options and a menu will 

appear. 
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3. You can choose the desired font style from the formatting options that appear. 

  

Format Font Color 

Changing the font color of your text can help emphasize the most important points 

and highlight topics. Here are the steps to change your font color. 

1. Select the text for which you wish to change the color. 
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2. Select a color from the palette to change the font color. You can choose the More 

Colors… option if you are looking for more colors. Here you can choose from preset colors 

or choose a custom color. 
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3. Click OK and your font color changes. 

 

Additionally, there is another method to format font color. After selecting the text, right-

click to open the formatting options and choose the font color of your choice. 
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Highlight Text in Word 

In Word, the Highlight feature lets you highlight important text in your document. 

The steps to highlight text in Word are as follows: 

1. Select the text that you wish to highlight. 
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2. Click on the downward arrow beside the Text Highlight Color button in the Font group 

of the Home tab to open the associated drop-down menu. 

  

3. From the dropdown menu that appears, choose the color for highlighting your text and 

select it. 
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You can also highlight your text using the right mouse button. The following steps show 

how you can highlight your text using your mouse. 

1. Select the text that you wish to highlight and click on the right mouse button. A related 

menu will appear with several formatting options. 

 

2. From the formatting options, click on the downward arrow beside the Text Highlight 

Color button. A list of possible highlight colors appears. 
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3. Choose the required color that you wish to use for your highlight and click on it. 

 

 

You will now see that the selected text is highlighted with the color that you chose. 
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To remove the highlight, select the highlighted part and open the dropdown along the Text 

Highlight Color button. 

Select No Color option and your highlight will be removed. 

 

To Change a Text Case 

Changing the text case is one of the most basic formatting tasks you can come across 

while using Word for studies or work. Here are the steps to follow to change the text case 

in Word. 

1. Select the text for changing the case. 
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2. Under the Home tab, choose the Change Case option. The respective dropdown menu 

appears. 
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3. From the dropdown menu, select the appropriate choice to change the text case as 

required. 

 

The different options that appear in the dropdown menu, and their description are as 

follows: 

 Sentence case.: It capitalizes the first word of a sentence while keeping all others as 

lowercase. If a word in between starts with uppercase, it is treated as a proper noun. 

 lowercase: It changes all the selected text to lower case. 

 UPPERCASE: Changes selected text to uppercase. 

 Capitalize Each Word: Use this option to capitalize the first letter of each word. 

 tOGGLE cASE: Text in uppercase is changed to lowercase, and vice versa 
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To Format Text Alignment 

Word offers 4 types of text alignment. They are Left Alignment, Centre Alignment, 

Right Alignment, and Justified Alignment. You can format the alignment of text from the 

Paragraph group under the Home tab. However, make a note that the alignment formatting 

applies to the whole paragraph. Even if you choose a part of a paragraph, the alignment of 

the whole paragraph would change. 

Left Alignment is the default alignment of every Word document. To change the alignment 

of your text, select the paragraph and choose the necessary alignment. 

 

Otherwise, you can also select the paragraph and use the keyboard shortcuts to align the 

text. 
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Alignment Keyboard Shortcut 

Left Alignment Ctrl + L 

Centre Alignment Ctrl + E 

Right Alignment Ctrl + R 

Justified Alignment Ctrl + J 

Special Formatting in Word 

There are a few special formattings in Word that are very useful for documentation 

purposes. Bold, Underline, Italic, Strikethrough, Superscript, and Subscript fall under 

special formatting features. We will look into how each of these affects your text and how 

you can apply the same to your text. 

Making Text Bold in Word 

Bold refers to making the letters of the text thicker and more prominent. To make your text 

bold, select your text and do any of the following: 

1. Select the Bold icon from the Font group under the Home tab. 
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Or, 

2. Right-click on your mouse to make the mini-menu appear. From there, select the icon 

for Bold. 

 

Or, 
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3. Use the keyboard shortcut Ctrl + B. 

 

Making Text Italic in Word 

Italic makes the font slanting and italic. To italicize your text, select your text and do any 

one of the following: 

1. Select the Italic icon from the Font group under the Home tab. 

 

Or, 
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2. Right-click on your mouse to make the mini-menu appear. From there, select the icon 

for Italic. 

 

Or, 

3. Use the keyboard shortcut Ctrl + I. 
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Underlining Text in Word 

The Underline icon is used to underline your text. You can do any one of the 

following to underline your text after you have selected it. 

1. Select the Underline icon from the Font group under the Home tab. Here, you can also 

choose the type of underline you wish to apply. 

 

 

Or, 

2. Right-click on your mouse to make the mini-menu appear. From there, select the icon 

for Underline. 
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You can choose the style of underline from the drop-down menu associated with 

the Underline button in the Font group of Home tab. 
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Or, 

Use the keyboard shortcut Ctrl + U. 

 

Adding Superscript in Word 

The ps while writing exponents in mathematics as well as while mentioning the 

specifications of chemicals in chemistry. The steps to use superscript in Word are given 

below. 

1. Place your cursor at the position where you wish to insert superscript and click on the 

Superscript button. 

 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 92       
   

2. Click on the Start typing. This text will be written as superscript. 

  

3. After you finish writing text in superscript and wish to go back to normal, click on 

the Superscript button again. Your cursor will go back to normal size and you will not be 

able to write normally again. 
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If you have already written text that you wish to convert to superscript, you can select it 

and click on the Superscript button under the Font group of the Home tab. 

 

 

Adding Subscript in Word 

Similarly, you can use the Subscript button to type small letters or text below your 

line of text. It helps while writing chemical formulas or the atomic number of elements in 

Chemistry. The steps to use Subscript in Word are given below. 

1. Place your cursor at the position where you wish to insert subscript and click on 

the Subscript button. 
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2. Click on the Start typing. This text will be written as subscript. 
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3. After you finish writing text in subscript and wish to go back to normal, click on 

the Subscript button again. Your cursor will go back to normal size and you will not be 

able to write normally again. 

 

If you have already written text that you wish to convert to subscript, you can select it and 

click on the Subscript button under the Font group of the Home tab. 
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Strikethrough in Word 

To strike through text in a Word document, select the text and click on the 

Strikethrough button under the Font group of Home tab. 
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Format Painter in Word 

In Word, Format Painter is an advanced tool that allows users to copy the formatting 

of a particular section of their document and paste the formatting to another section. As 

such, the two sections of your document will have similar formatting. Follow the steps 

given below to use the Format Painter feature in Word. 

1. Choose the section whose formatting you wish to copy. 

 

2. Click on the Format Painter option under the Clipboard section of the Home tab. This 

copies the formatting of the initial section. You can also use the keyboard shortcut Ctrl + 

Shift + C for copying the formatting of the initial section. 
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3. If you hover over the destination section, you will notice that your mouse pointer changes 

to a brush. Select the destination section to paste the formatting of the initial section. 
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4. If you have copied the formatting using the keyboard shortcut, then select the destination 

section and use the keyboard shortcut Ctrl + Shift + V to paste the formatting. 

 

If you wish to paste the same formatting to multiple parts of your document, then follow 

the steps below. 

1. Select the text section whose format you wish to copy. 

2. Double click on the Format Painter option under the Clipboard group of Home tab of 

your Word window. 

3. Paste the formatting to other sections of your document by selecting them. 

4. Once done, use the Esc key, or click on the Format Painter option under 

the Clipboard group of Home tab to exit. 
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Clear Formatting in Word 

In Word, you can clear the formatting that you have applied to the text in your 

document by following the steps given below. 

1. Select the text in your document where you wish to clear the formatting. You can select 

the whole document if you wish to reset the formatting of the whole document. 

 

2. Click the Clear All Formatting button under the Font group of the Home tab to clear 

formatting. Alternatively, you can also use the keyboard shortcut Ctrl + SPACEBAR. 
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Being able to reset your formatting lets you take control whenever you make some errors 

unconsciously. 

 

Since you now know how to format text in Word, you can use these tools to format 

your document properly. Properly formatting text in Word will help you draw the reader’s 
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attention to the important parts and also have a better effect during presentations. Try out 

these formatting tools in Word to become better acquainted with them. 

How to Use the Spelling and Grammar Check in Microsoft Word 

How to Include or Exclude Grammar 

1. Select the File tab. 

 

2. Select Options in the Backstage view. 
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3. Select Proofing in the Word Options dialog box. 
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4. Select or deselect Check grammar with spelling. 
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5. Select the OK button to save your selection and close the Word Options dialog box. 

 

To Run the Spelling and Grammar Check 

1. Select the Review tab. 
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2. Select Spelling & Grammar. 

 

3. Choose the appropriate option for each spelling and grammar error detected. 

Spelling Errors 

Choose an option from the suggestions list to change that instance of the spelling error. 
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Or, open the drop-down menu for a suggestion and select Change All to change every 

instance of the spelling error to that suggestion. 

 

You can also choose (a) Add to Dictionary to add the word with its current spelling to 

your custom dictionary, (b) Ignore Once to ignore that instance of the spelling error, or 

(c) Ignore All to ignore every instance of the spelling error. 

https://erinwrightwriting.com/edit-custom-dictionary-word/


    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 108       
   

 

Occasionally, Word will be unable to provide any suggestions; however, when that lapse 

occurs, the software will still offer the opportunity to add the word to your custom 

dictionary, ignore the word once, or ignore every instance of the word. 

Grammar Errors 

Choose an option from the suggestions list to change that instance of the grammar error. 
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Or, select (a) Ignore Once to ignore that instance of the grammar error, (b) Don’t check 

for this issue to stop checking for that type of grammar error, or (c) Options for “Clarity 

and Conciseness” to open the Grammar Settings dialog box where you can customize the 

grammar check. 

 

If you want to learn about the grammar error and see examples, open the drop-down menu 

above the text box. 
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Pro Tip: The spelling and grammar check will automatically pause itself if you edit the 

text during the check. Select the Resume button when you are ready to restart the check. 

 

If you have chosen to include readability statistics in your proofing options, the 

Readability Statistics dialog box will appear after you complete the spelling and grammar 

check. 

Working with Tables in MS Word 

Microsoft Word or MS-WORD is a graphical word processing program that users 

can type with. It allows the users to type and save documents very similar to other word 

processors. There are many versions of MS-word in market, which the user can install as 

per te. In this tutorial, we will learn about the tables in MS-Word.  

Tables in MS Word are made up of rows and columns with an organized 

arrangement of text. These tables can be used to align numbers in columns and then 

various operations can be performed on them. Tables can also be used to create page 
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layouts. Rows in a table are series of data banks laid out horizontally in a table or 

spreadsheet. Columns are vertical series of cells in a chart, table, or spreadsheet. 

TO CREATE A TABLE 

Tables in MS Word can be created in the following two ways: 

1. Using the Grid 

2. Using Table Dialogue Box 

Using the Grid 

Following are the steps of creating a table using the Grid provided in MS Word: 

Step 1: Go to the Insert tab and click on the Table button. 

 

 

 

Step 2: In the dropdown menu, select the number of rows and columns from the Grid. 
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Using Table Dialogue Box 

Following are the steps of creating a table using Table Dialogue Box in MS Word: 

Step 1: Go to the Insert tab and click on the Table button. 

 

 

 

Step 2: Under the grid, you will see an Insert Table button. Click on it. 
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Step 3: In the Insert Table Dialogue box, mention the number of rows and number of 

columns as per the requirement and click on OK button. 

How to Modify a Table? 

We can also edit/modify a table to make it more creative. Multiple operations can be 

performed on a table like changing the layout, splitting of cells, merging the cells, 

applying borders, etc. Here, we will see some of the operations performed on a table in 

MS Word. 

Changing Layout of a Table 

Changing the layout of a table can be done with the help of the following steps:  

Step 1: Select the table for which the layout is to be changed. Go to the design tab. 
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Step 2: Click on the dropdown menu to get various different types of layouts for your 

table. 

 

Step 3: Select any layout as per the need. 
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Splitting the Cell 

Splitting of a cell can be done with the help of the following steps: 

Step 1: Select the cell that you want to split into multiple cells. Then go to the Layout 

tab and click on the Split Cells button. 

 

Step 2: In the dialogue box, mention the new dimensions as per the requirement.  
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Step 3: Click on the Ok button. 

 

 

Merging the Cells 

Merging of various cells can be done by the following steps: 

Step 1: Select all the cells that are to be merged into a single cell. Then go over the layout 

tab, and you will see a Merge Cell button. 
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Step 2: Now click on the Merge Cell button and the selected cells will be merged. 

 

 

Applying Borders and Styles on a Table 

Borders and styles can also be applied to a table in a similar way as the layout of 

a table is changed. Go through the following steps to do the same: 

Step 1: Select the entire table and go over the design tab. 
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Step 2: Select the style that you want to apply to your table. 

 

 

Converting Text to a Table 

MS Word allows the conversion of existing text into a table with the help of the 

following steps: 
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Step 1: Select the text that is to be converted into the table. Now go to the Insert Tab and 

you will see a Table button. 

 

Step 2: Click on the Insert Table button and in the drop-down menu, click on 

the Convert Text to Table button. 

 

 

Step 3: In the dialogue box, mention the dimensions of the required table and other data 

that is required.  
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Step 4: Click on the OK button and the selected text will be converted to a Table. 

 

 

Inserting Images in a Table 

MS Word allows adding images inside the table cells. To insert an image in a table, 

go through the following steps: 

Step 1: Select the cell in which you want to add the Image. Go to the Insert tab and 

select the Pictures button. 
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Step 2: You can either choose a picture from your device or select one online. 

Step 3: Choose a picture from the browser window and click on the Insert button. 

 

 

Step 4: Selected Image will be added in the cell selected. 
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Performing Calculations in a Table 

Mathematical calculations can also be performed on the values present in the table. 

Microsoft provides various formulas to perform these operations. By default, the sum of 

the values lying in the rows to the left or column lying above are calculated by Word. 

Following are the steps to do the same: 

Step 1: Select the cell in which the result of the mathematical operations is required.  

 

 

Step 2: Now go to the Layout tab and select the formula button.  
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Step 3: In the dialogue box, define the formula for the mathematical operation, the default 

formula is the sum of the values to the left or above. 

 

Step 4: After defining the formula, click on the OK button to apply the formula on the 

cells given in the formula. 
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To Use Mail Merge in Microsoft Word 

Mail Merge is most often used to print or email form letters to multiple recipients. 

Using Mail Merge, you can easily customize form letters for individual recipients. Mail 

merge is also used to create envelopes or labels in bulk. 

This feature works the same in all modern versions of Microsoft Word: 2010, 2013, and 

2016. 

1. In a blank Microsoft Word document, click on the Mailings tab, and in the Start 

Mail Merge group, click Start Mail Merge. 
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2. Click Step-by-Step Mail Merge Wizard 

 

3. Select your document type. In this demo we will select Letters. 

Click Next:Starting   
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4. Select the starting document. In this demo we will use the current (blank) 

document. Select Use the current document and then click Next: Select 

recipients. 

 

1. Note that selecting Start from existing document (which we are not doing 

in this demo) changes the view and gives you the option to choose your 

document. After you choose it, the Mail Merge Wizard reverts to Use the 

current document. 
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5. Select recipients. In this demo we will create a new list, so select Type a new 

list and then click Create. 
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1. Create a list by adding data in the New Address List dialog box and 

clicking OK.

 

2. Save the list. 

3. Note that now that a list has been created, the Mail Merge Wizard reverts 

to Use an existing list and you have the option to edit the recipient list. 
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4. Selecting Edit recipient list opens up the Mail Merge Recipients dialog 

box, where you can edit the list and select or unselect records. Click OK to 

accept the list as is. 

 

5. Click Next: Write your letter. 

6. Write the letter and add custom fields. 
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1. Click Address block to add the recipients' addresses at the top of the document.

 

2. In the Insert Address Block dialog box, check or uncheck boxes and select 

options on the left until the address appears the way you want it to.
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3. Note that you can use Match Fields to correct any problems. Clicking Match 

Fields opens up the Match Fields dialog box, in which you can associate the 

fields from your list with the fields required by the wizard.
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7. Press Enter on your keyboard and click Greeting line... to enter a greeting.

 

8. In the Insert Greeting Line dialog box, choose the greeting line format by clicking 

the drop-down arrows and selecting the options of your choice, and then click OK.
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9. Note that the address block and greeting line are surrounded by chevrons (« »). 

Write a short letter and click Next: Preview your letters.

 

 Preview your letter and click Next: Complete the merge.
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 Click Print to print your letters or Edit individual letters to further personalize 

some or all of the letters. 

 

To use the Mail Merge feature in Word to create and to print form letters that use 

the data from an Excel worksheet 

When you use the Word Mail Merge feature, Word merges a main document with a 

recipient list to generate a set of output documents: 

 The main document contains the basic text that is the same in all of the output 

documents. It may contain a letterhead, text, and instructions in merge fields for 

inserting text (such as recipient names and addresses) that vary from one output 

document to another. 
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 The recipient list is a database that contains the data that is to be merged into the output 

documents. For example, the recipient list is a Microsoft Access database file or an 

Excel worksheet. 

 This database is typically a list of names, addresses, phone numbers, and other 

categories of personal information. 

 The output documents are the result of the mail merge. The text in an output document 

can be the same in all output documents, but you can apply formatting to specific 

documents. 

Step 1: Set Up the Excel Data File 

Before you proceed with the Mail Merge Wizard, make sure that your Excel worksheet is 

well structured for this purpose. Note the following requirements for the data table: 

 The first row should contain field names for each column -- for example, Title, 

Salutation, First Name, Middle Name, Last Name, Address1, and Address2. 

 Each field name should be unique. 

 Each row should provide information about a particular item. For example, in a 

mailing list, each row might include information about a particular recipient. 

 The table should contain no blank rows. 

Create your Excel data file, and then arrange it by using the fields that you want to use 

for your letter, as shown in the following sample data file. 

After you create your Excel data file, save it, and then close the data file. 
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Step 2: Set Up the Main Document 

1. In Microsoft Office Word 2003 and in earlier versions of Word, point to Letters and 

Mailings on the Tools menu, and then click Mail Merge Wizard. In Microsoft Office 

Word 2007, click Start Mail Merge in the Start Mail Merge group on 

the Mailings tab, and then click Step by Step by Mail Merge Wizard. 

2. Under Select document type, click Letters. 

The active document becomes the main document. The main document contains the 

text and graphics that are the same for each version of the merged document. For 

example, the return address and the salutation in a form letter are the same for each 

version. 

3. Click Next: Starting document. 

4. Use one of the following methods: 

 Start with the document that is currently shown in the document window. To do 

this, click Use the current document. 

You can then either type the letter in the document window or wait until the 

wizard prompts you to do so in a later step. 

 Start with a template. To do this, follow these steps: 

i. Click Start from a template. 

ii. Click Select template. 

iii. On the Mail Merge tab, select the template that you want in the Select Template 

dialog box, and then click OK. 

 Start with an existing document. To do this, follow these steps: 
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i. Click Start from existing document. 

ii. In the Start from existing box, select the document that you want, and then click 

Open. 

iii. If you do not see the document, click More files, and then click Open. In the Open 

dialog box, locate the document that you want, and then click Open. 

5. Click Next: Select recipients. 

Step 3: Specify the Excel Data Source 

1. Under Select recipients, click Use an existing list. 

2. Click Browse. 

3. In the Select Data Source dialog box, locate and then click the Excel worksheet that 

you want to use. 

By default, Word opens the "My Data Sources" folder. 

4. Click Open. 

5. If your Excel worksheet contains information about multiple tabs, select the tab that 

contains the information that you want, and then click OK. 

6. All entries in the data source appear in the Mail Merge Recipients dialog box. Here, 

you can refine the list of recipients to include in the merge. 

Step 4: Select the Recipients 

1. In the Mail Merge Recipients dialog box, select the recipients that you want to include. 

To do this, use one of the following methods: 
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 Use the check boxes to designate recipients. 

This method is most useful if the list is short. Click to select the check boxes 

next to the recipients that you want to include, and then click to clear the check 

boxes next to the recipients that you want to exclude. 

Note If you know that you want to include most of the list in your merge, click 

Select All, and then click to clear particular records. Similarly, if you want to 

include only a few records in the list, click Clear All, and then select the records 

that you want. 

 Sort items in the list. 

This method is useful if you want to see items in alphabetical or numeric order. 

Click the column heading of the element by which you want to sort. For 

example, if you want to display the list alphabetically by last name, click the 

Last Name column heading. 

 Filter items in the list. 

This method is useful if the list contains records that you know you do not want 

to see or include in the merge. After you have filtered the list, you can use the 

check boxes to include and exclude records, as described earlier. To filter the 

list, follow these steps: 

i. Click the arrow next to the column heading of the element that you want to filter 

by. 

ii. Click any of the following: 
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 (Blanks): This option displays all the records in which the corresponding field is 

blank. 

 (Nonblanks): This option displays all the records in which the corresponding field 

contains information. 

 If the data source contains records that share the same information, and if there are 

10 or fewer unique values in the column, you can filter by specific information. 

For example, if there are multiple addresses that list Australia as the country, you 

can filter by Australia. 

 The Mail Merge Recipients dialog box displays only the designated records. To 

display all the records again, click (All). 

Notes 

 For advanced sorting and filtering, click the arrow next to any column name, and 

then click (Advanced). Use the Filter Records and Sort Records tabs to set up the 

sorting or filtering query that you want. 

 If you have installed address validation software, click Validate in the Mail Merge 

Recipients dialog box to validate your recipients' addresses. 

2. Click OK to return to the Mail Merge Wizard. 

Word uses the recipients that you designated for the merge. 

3. Click Next: Write your letter. 
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Step 5: Complete the Letter and Add Merge Fields 

If you have not already done this, type the text that you want to appear in every form letter 

in the main document. 

Insert Merge Fields 

Insert merge fields where you want to merge names, addresses, and other information from 

the data source. To insert merge fields, follow these steps: 

1. In the main document, click where you want to insert the field. 

2. Insert any of the following: 

 Address block with name, address, and other information: 

i. Click Address block. 

ii. In the Insert Address Block dialog box, select the address elements that you want 

to include and the formats that you want, and then click OK. For help on an 

option, click the question mark, and then click the option. 

 

iii. For help on an option, click the question mark, and then click the option. If the 

Match Fields dialog box appears, Word may be unable to find some of the 

information it needs for the address block. Click the arrow next to 

(not available), and then select the field from your data source that corresponds 

to the field required for the mail merge. 

 Greeting line: 

i. Click Greeting line. 
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ii. Select the greeting line format that includes the salutation, name format, and 

following punctuation. 

iii. Select the text that you want to appear in the cases in which Word cannot interpret 

the recipient's name. For example, Word cannot interpret the name when the data 

source contains no first or last name for a recipient, but only a company name. 

iv. Click OK. 

v. If the Match Fields dialog box appears, Word may be unable to find some of the 

information it needs for the greeting line. Click the arrow next to (not available), 

and then select the field from your data source that corresponds to the field 

required for the mail merge. 

 Other fields of information: 

i. Click More items. 

ii. Use one of the following methods: 

 Click Address Fields to select from address fields that will automatically map to 

corresponding fields in your data source, even if the data source's fields do not 

have the same name as your fields. 

 Click Database Fields to select from fields that always take data directly from a 

column in a database. 

iii. In the Fields box, click the field that you want. 

iv. Click Insert, and then click Close. 

v. If the Match Fields dialog box appears, Word may not be able to find some of 

the information it needs to insert the field. Click the arrow next to (not 
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available), and then select the field from your data source that corresponds to the 

field required for the mail merge. 

Note If you insert a field from the Database Fields list, and if you later switch to 

a data source that does not have a column with the same name, Word cannot 

insert that field information into the merged document. 

 Electronic postage: 

To add electronic postage, you must first install an electronic postage program, 

such as one that you can purchase from a third-party provider on the Web. To 

use electronic postage, follow these steps: 

i. Click Electronic postage. 

If you do not have an electronic postage program installed, Word prompts you to 

install one, and offers to connect to the following Microsoft Office Web site: 

ii. Insert the postage according to the program's instructions. 

 To add electronic postage, you must first install an electronic postage program, 

such as one that you can purchase from a third-party provider on the Web. To use 

electronic postage, follow these steps:Postal bar code: You must select a letter or 

envelope type that supports the POSTNET bar code. To use the Postal bar code, 

follow these steps: 

i. Click Postal Bar Code. 

ii. In the Insert Postal Bar Code dialog box, select the appropriate address fields. 

Note The Postal Bar Code option appears only if you are using the U.S. language 

version of Word. 
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iii. Repeat steps a and b for all the fields that you want to insert. NOTES: 

 You cannot type merge field characters (" ") or insert them by using the Symbol 

command on the Insert menu. 

 If the merge fields appear inside braces, such as { MERGEFIELD City }, Word is 

displaying field codes instead of field results. This does not affect the merge, but 

if you want to display the results instead, right-click the field code, and then click 

Toggle Field Codes on the shortcut menu. 

For example, by using the sample database shown earlier, your letter might 

contain the AddressBlock and GreetingLine fields, and therefore your first page 

appears similar to the following: 

February 26, 2002 

 

AddressBlock 

 

GreetingLine 

 

Type your letter here. 

 

Sincerely, 

 

Type your name here 

 

3. Note You can also use the Mail Merge toolbar to insert merge fields, work with your 

mail-merge main document, or run a mail merge. To display the Mail Merge toolbar, 
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point to Letters and Mailings on the Tools menu, and then click Show Mail Merge 

Toolbar. 

   The Mail Merge toolbar provides additional commands that are not 

included in the Mail Merge Wizard task panes. For example, you can use the Insert 

Word Field menu on the Mail Merge toolbar to insert Word fields for controlling the 

merge process. For example, you can insert an IF field that inserts text only if a 

particular merge field has a specified value. 

Alternatively, you can click Check For Errors to make Word run the mail merge and 

report any errors that are contained in the main document. 

Change the Format of the Merged Data 

To format merged data, you must format the merge fields in the main document. Do 

not format the data in the data source, because its formatting is not retained when you 

merge the data into the document. To change the format of the merged data, follow these 

steps: 

1. In the main document, select the field that contains the information that you want to 

format, including the enclosing merge field characters (<< >>). 

2. In Word 2003 and in earlier versions of Word, click Font on the Format menu, and 

then select the options that you want. 

In Word 2007, click the option that you want in the Theme Fonts box in 

the Font group on the Home tab. 
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Format by Using Field Codes 

To control other aspects of formatting, press ALT+F9 to display field codes, and then add 

switches to the merge fields. When you work with fields, a switch is a special instruction 

that causes a specific action to occur. Generally, a switch is added to a field to modify a 

result. 

Examples of how to use switches are as follows: 

 To display the number 34987.89 as $34,987.89, add the Numeric Picture switch (\#). 

 To print client names in uppercase letters, add the Format switch (\*). 

 To make sure that the merged information has the same font and point size that you 

apply to the merge field, add the Charformat switch (\*). 

Step 6: Save the Document 

After you have completed the main document and inserted all the merge fields, make sure 

that you save the document before proceeding. To do this, follow these steps: 

1. In Word 2003 and in earlier versions of Word, click Save As on the File menu. 

In Word 2007, click the Microsoft Office Button, and then click Save As. 

2. Name the document, and then click Save. 

3. Click Next: Preview your letters. 
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Step 7: Preview the Letters and Fine-Tune the Recipient List 

When the wizard displays the "Step 5 Mail Merge" task pane, the wizard replaces each of 

the merge fields in the main document that has the actual text from the first entry of the 

recipient list.Therefore, you can see how your first output document will look. 

For example, if you were to continue to use the sample database shown earlier, the first 

page should resemble the following page after you click Next: Preview your letters: 

February 26, 2002 

 

Andrew Fuller 

908 W. Capital Way 

Tacoma 98401 

 

Dear Andrew Fuller, 

 

Type your letter here. 

 

Sincerely, 

Type your name here To preview additional entries, use one of the following methods: 

 To preview the items in order, click the left or right arrow buttons. 

 To locate and preview a specific item, click Find a recipient, and then enter the search 

criteria in the Find Entry dialog box. 

Fine-tune the recipient list if you want. To do this, use one of the following methods: 

 To exclude a particular recipient from the merge operation, click Exclude this 

recipient. 
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 To change the list of recipients, click Edit recipient list, and then make your changes 

in the Mail Merge Recipients dialog box. 

Step 8: Complete the Merge 

To complete the merge, use any of the following methods. 

Personalize Individual Letters 

To personalize individual items, you actually complete the merge, and then edit the 

information that you want in the resulting merged document. To do this, follow these steps: 

1. Click Edit individual letters. 

2. In the Merge to New Document dialog box, select the records that you want to merge. 

3. Click OK. 

Word creates and opens a new merged document. Your main document also remains 

open, and you can switch back to it if you want to change all the documents. 

4. Scroll to the information that you want to edit, and then make your changes. 

5. Print or save the document just as you would any regular document. 

Print the Letters 

To print the letters, use one of the following methods: 

 If you personalized the items and if the merged document is active, follow these steps: 

a. In Word 2003 and in earlier versions of Word, click Print on the File menu. 

In Word 2007, click the Microsoft Office Button, and then click Print. 
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b. Select the options that you want. 

 If you want to print directly from the Mail Merge Wizard, follow these steps: 

a. In Step 6 of the Mail Merge Wizard (Complete the merge), click Print. 

b. In the Merge to Printer dialog box, use one of the following methods, and then 

click OK: 

 To print all the documents, click All. 

 To print the document that you see in the document window, click Current record. 

 To print a range of documents, click From, and then type the record numbers in the 

From and To boxes. 

c. In the Print dialog box, select the options that you want. 

Save the Merged Letters for Later Use 

If you want to edit merged letters or to save them for later use, you can collect them into a 

single document. To do this, follow these steps: 

1. Click Edit individual letters. 

2. In the Merge to a New Document dialog box, use one of the following methods, and 

then click OK: 

 To merge all the documents, click All. 

 To merge only the document that you see in the document window, click Current 

record. 

 To merge a range of documents, click From, and then type the record numbers in 

the From and To boxes. 
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3. Word opens a single new document that contains all the individual letters. You can 

then save the document for later use, just as you would any regular document. 

UNIT – III 

MS POWER POINT 

INTRODUCTION TO MICROSOFT POWERPOINT 

Information can be displayed using an electronic presentation application. This 

information is usually presented as a slide show - the data is displayed on a slide that may 

be viewed on a computer monitor or projected onto a screen using an LCD projector. A 

presentation might consist of multiple slides that are exhibited one after the other. The 

presentation tool in MS Office is MS PowerPoint. Microsoft PowerPoint is a popular 

presentation application, although there are alternatives such as Corel Presentations 

OpenOffice.org, Impress, etc.  

PowerPoint files are called presentations. Whenever you start a new project in 

PowerPoint, you'll need to create a new presentation, which can either be blank or from 

a template. You'll also need to know how to open an existing presentation. 

To create a new presentation: 

When beginning a new project in PowerPoint, you'll often want to start with a new 

blank presentation. 

1. Select the File tab to go to Backstage view. 
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2. Select New on the left side of the window, then click Blank Presentation. 

 

 

3. A new presentation will appear. 

TO CREATE A NEW PRESENTATION FROM A TEMPLATE: 

A template is a predesigned presentation you can use to create a new slide show 

quickly. Templates often include custom formatting and designs, so they can save you a 

lot of time and effort when starting a new project. 

1. Click the File tab to access Backstage view, then select New. 
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2. You can click a suggested search to find templates or use the search bar to 

find something more specific. In our example, we'll search for the 

keyword chalkboard. 

 

3. Select a template to review it. 
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4. A preview of the template will appear, along with additional 

information on how the template can be used. 

5. Click Create to use the selected template. 

 

6. A new presentation will appear with the selected template. 

To open an existing presentation: 

In addition to creating new presentations, you'll often need to open a presentation 

that was previously saved. To learn more about saving presentations, review our lesson 

on Saving Presentations. 

1. Select the File tab to go to Backstage view, then click Open. 

https://edu.gcfglobal.org/en/powerpoint/saving-presentations/1/
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2. Click Browse. You can also choose OneDrive to open files stored on your 

OneDrive. 

 

3. The Open dialog box will appear. Locate and select your presentation, then 

click Open. 
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Most features in Microsoft Office, including PowerPoint, are geared toward saving 

and sharing documents online. This is done with OneDrive, which is an online storage 

space for your documents and files. If you want to use OneDrive, make sure you’re signed 

in to PowerPoint with your Microsoft account. Review our lesson on Understanding 

OneDrive to learn more. 

To pin a presentation: 

If you frequently work with the same presentation, you can pin it to Backstage view for 

easy access. 

1. Select the File tab to go to Backstage view, then click Open. Your Recent 

Presentations will appear. 

https://edu.gcfglobal.org/en/powerpoint/understanding-onedrive/1/
https://edu.gcfglobal.org/en/powerpoint/understanding-onedrive/1/
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2. Hover the mouse over the presentation you want to pin, then click 

the pushpin icon. 

 

3. The presentation will stay in the Recent presentations list until it is 

unpinned. To unpin a presentation, click the pushpin icon again. 

 

Compatibility Mode 

Sometimes you may need to work with presentations that were created in earlier 

versions of PowerPoint, like PowerPoint 2003 or PowerPoint 2000. When you open these 

types of presentations, they will appear in Compatibility Mode. 
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Compatibility Mode disables certain features, so you'll only be able to access 

commands found in the program that was used to create the presentation. For example, if 

you open a presentation created in PowerPoint 2003, you can only use tabs and commands 

found in PowerPoint 2003. 

In the image below, you can see at the top of the window that the presentation is in 

Compatibility Mode. This will disable some current PowerPoint features, including newer 

types of slide transitions. 

 

To exit Compatibility Mode, you'll need to convert the presentation to the current version 

type. However, if you're collaborating with others who only have access to an earlier 

version of PowerPoint, it's best to leave the presentation in Compatibility Mode so the 

format will not change. 

You can review this support page from Microsoft to learn more about which features are 

disabled in Compatibility Mode. 

http://office.microsoft.com/en-us/powerpoint-help/powerpoint-2013-features-behave-differently-in-earlier-versions-HA102893464.aspx?CTT=5&origin=HA102893492
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To convert a presentation: 

If you want access to the newer features, you can convert the presentation to the current 

file format. 

Note that converting a file may cause some changes to the original layout of the 

presentation. 

1. Click the File tab to access Backstage view. 

 

2. Locate and select the Convert command. 
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3. The Save As dialog box will appear. Select the location where you want to 

save the presentation, enter a file name, and click Save. 

 

4. The presentation will be converted to the newest file type. 

Challenge 

1. Open our practice presentation. 

2. Notice that the presentation opens in Compatibility Mode. Convert it to the 

current file format. If a dialog box appears asking if you would like to close 

and reopen the file in order to see the new features, choose Yes. 

3. In Backstage view, pin a file or folder. 

https://media.gcflearnfree.org/content/5c09234b77c0500354728513_12_06_2018/powerpoint_creatingopening_practice.ppt
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Save and Save As 

PowerPoint offers two ways to save a file: Save and Save As. These options work in similar 

ways, with a few important differences. 

 Save: When you create or edit a presentation, you'll use the Save command 

to save your changes. You'll use this command most of the time. When you 

save a file, you'll only need to choose a file name and location the first time. 

After that, you can just click the Save command to save it with the same 

name and location. 

 Save As: You'll use this command to create a copy of a presentation while 

keeping the original. When you use Save As, you'll need to choose a 

different name and/or location for the copied version. 

About OneDrive 

Most features in Microsoft Office, including PowerPoint, are geared toward saving and 

sharing documents online. This is done with OneDrive, which is an online storage space 

for your documents and files. If you want to use OneDrive, make sure you’re signed in to 

PowerPoint with your Microsoft account. Review our lesson on Understanding 

OneDrive to learn more. 

To save a presentation: 

It's important to save your presentation whenever you start a new project or make changes 

to an existing one. Saving early and often can prevent your work from being lost. You'll 

https://edu.gcfglobal.org/en/powerpoint/understanding-onedrive/1/
https://edu.gcfglobal.org/en/powerpoint/understanding-onedrive/1/
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also need to pay close attention to where you save the presentation so it will be easy to 

find later. 

1. Locate and select the Save command on the Quick Access Toolbar. 

 

2. If you're saving the file for the first time, the Save As pane will appear 

in Backstage view. 

3. You'll then need to choose where to save the file and give it a file name. 

Click Browse to select a location on your computer. You can also 

click OneDrive to save the file to your OneDrive. 
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4. The Save As dialog box will appear. Select the location where you want to 

save the presentation. 

5. Enter a file name for the presentation, then click Save. 

 

6. The presentation will be saved. You can click the Save command again to 

save your changes as you modify the presentation. 

You can also access the Save command by pressing Ctrl+S on your keyboard. 

Using Save As to make a copy 

If you want to save a different version of a presentation while keeping the original, 

you can create a copy. For example, if you have a file named Client Presentation you 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 162       
   

could save it as Client Presentation 2 so you'll be able to edit the new file and still refer 

back to the original version. 

To do this, you'll click the Save As command in Backstage view. Just like when saving a 

file for the first time, you'll need to choose where to save the file and give it a new file 

name. 

 

To change the default save location: 

If you don't want to use OneDrive, you may be frustrated that OneDrive is selected as the 

default location when saving. If you find this inconvenient, you can change the default 

save location so This PC is selected by default. 

1. Click the File tab to access Backstage view. 
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2. Click Options. 

 

3. The PowerPoint Options dialog box will appear. Select Save, check the 

box next to Save to Computer by default, then click OK. The default save 

location will be changed. 
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Using AutoRecover 

  PowerPoint automatically saves your presentations to a temporary folder 

while you are working on them. If you forget to save your changes or if PowerPoint 

crashes, you can restore the file using AutoRecover. 

To use AutoRecover: 

1. Open PowerPoint. If autosaved versions of a file are found, 

the Document Recovery pane will appear. 

2. Click to open an available file. The presentation will be recovered. 
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By default, PowerPoint autosaves every 10 minutes. If you are editing a presentation for 

less than 10 minutes, PowerPoint may not create an autosaved version. 

If you don't see the file you need, you can browse all autosaved files from Backstage view. 

Just select the File tab, click Manage Presentation, then choose Recover Unsaved 

Presentations. 
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Exporting presentations 

By default, PowerPoint presentations are saved in the .pptx file type. However, there may 

be times when you need to use another file type, such as a PDF or PowerPoint 97-2003 

presentation. It's easy to export your presentation from PowerPoint to a variety of file 

types. 

 PDF: This saves the presentation as a PDF document instead of a 

PowerPoint file. 

 Video: This saves the presentation as a video. 

 Package for CD: This saves the presentation in a folder along with the 

Microsoft PowerPoint Viewer, a special slide show player anyone can 

download. 

 Handouts: This prints a handout version of your slides. 
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 Other file type: This saves in other file types, 

including PNG and PowerPoint 97-2003. 

To export a presentation: 

In our example, we'll save the presentation as a PowerPoint 97-2003 file. 

1. Click the File tab to access Backstage view. 

2. Click Export, then choose the desired option. In our example, we'll 

select Change File Type. 

 

3. Select a file type, then click Save As. 
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4. The Save As dialog box will appear. Select the location where you want to 

export the presentation, type a file name, then click Save. 
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You can also use the Save as type drop-down menu in the Save As dialog box to save 

presentations in a variety of file types. Be careful to choose a file type others will be able 

to open. 
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Sharing presentations 

PowerPoint makes it easy to share and collaborate on presentations 

using OneDrive. In the past, if you wanted to share a file with someone you could send it 

as an email attachment. While convenient, this system also creates multiple versions of 

the same file, which can be difficult to organize. 
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When you share a presentation from PowerPoint, you're actually giving others 

access to the exact same file. This lets you and the people you share with edit the same 

presentation without having to keep track of multiple versions. 

In order to share a presentation, it must first be saved to your OneDrive. 

To share a presentation: 

1. Click the File tab to access Backstage view, then click Share. 

 

PowerPoint will return to Normal view and open the Share panel on the right side 

of the window. From here, you can invite people to share your document, see a list 

of who has access to the document, and set whether they can edit or only view the 

document. 
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Understanding slides and slide layouts 

When you insert a new slide, it will usually have placeholders to show you where 

content will be placed. Slides have different layouts for placeholders, depending on the 

type of information you want to include. Whenever you create a new slide, you'll need to 

choose a slide layout that fits your content. 
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Placeholders can contain different types of content, including text, images, and videos. 

Many placeholders have thumbnail icons you can click to add specific types of content. 

In the example below, the slide has placeholders for the title and content. 

 

To insert a new slide: 

Whenever you start a new presentation, it will contain one slide with the Title 

Slide layout. You can insert as many slides as you need from a variety of layouts. 

1. From the Home tab, click the bottom half of the New Slide command. 

 

2. Choose the desired slide layout from the menu that appears. 
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3. The new slide will appear. Click any placeholder and begin typing to add 

text. You can also click an icon to add other types of content, like 

a picture or chart. 

 

To change the layout of an existing slide, click the Layout command, then choose the 

desired layout. 
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To quickly add a slide that uses the same layout as the selected slide, click the top half of 

the New Slide command. 

 

Organizing slides 

PowerPoint presentations can contain as many slides as you need. The Slide 

Navigation pane on the left side of the screen makes it easy to organize your slides. From 

there, you can duplicate, rearrange, and delete slides in your presentation. 
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Working with slides 

 Duplicate slides: If you want to copy and paste a slide quickly, you 

can duplicate it. To duplicate slides, select the slide you want to duplicate, 

right-click the mouse, and choose Duplicate Slide from the menu that 

appears. You can also duplicate multiple slides at once by selecting them 

first. 
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 Move slides: It's easy to change the order of your slides. Just click and drag 

the desired slide in the Slide Navigation pane to the desired position. 

 

 Delete slides: If you want to remove a slide from your presentation, you 

can delete it. Simply select the slide you want to delete, then press 

the Delete or Backspace key on your keyboard. 

To copy and paste slides: 

If you want to create several slides with the same layout, you may find it easier to copy 

and paste a slide you've already created instead of starting with an empty slide. 
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1. Select the slide you want to copy in the Slide Navigation pane, then click 

the Copy command on the Home tab. You can also press Ctrl+C on your 

keyboard. 

 

2. In the Slide Navigation pane, click just below a slide (or between two slides) 

to choose a paste location. A horizontal insertion point will appear. 
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3. Click the Paste command on the Home tab. You can also press Ctrl+V on 

your keyboard. 
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4. The slide will appear in the selected location. 

 

Customizing slide layouts 

Sometimes you may find that a slide layout doesn't exactly fit your needs. For 

example, a layout might have too many—or too few—placeholders. You might also want 

to change how the placeholders are arranged on the slide. Fortunately, PowerPoint makes 

it easy to adjust slide layouts as needed. 
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Adjusting placeholders 

 To select a placeholder: Hover the mouse over the edge of the placeholder 

and click (you may need to click the text in the placeholder first to see the 

border). A selected placeholder will have a solid line instead of a dotted line. 

 

 To move a placeholder: Select the placeholder, then click and drag it to the 

desired location. 

 

 To resize a placeholder: Select the placeholder you want to resize. Sizing 

handles will appear. Click and drag the sizing handles until the placeholder 

is the desired size. You can use the corner sizing handles to change the 

placeholder's height and width at the same time. 
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 To delete a placeholder: Select the placeholder you want to delete, then 

press the Delete or Backspace key on your keyboard. 

To add a text box: 

Text can be inserted into both placeholders and text boxes. Inserting text boxes allows 

you to add to the slide layout. Unlike placeholders, text boxes always stay in the same 

place, even if you change the theme. 

1. From the Insert tab, select the Text Box command. 

 

2. Click and drag to draw the text box on the slide. 
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3. The text box will appear. To add text, simply click the text box and begin 

typing. 

 

Using blank slides 

If you want even more control over your content, you may prefer to use a blank slide, 

which contains no placeholders. Blank slides can be customized by adding your own text 

boxes, pictures, charts, and more. 

 To insert a blank slide, click the bottom half of the New Slide command, 

then choose Blank from the menu that appears. 
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While blank slides offer more flexibility, keep in mind that you won't be able to take 

advantage of the predesigned layouts included in each theme. 

To play the presentation: 

Once you've arranged your slides, you may want to play your presentation. This is how 

you will present your slide show to an audience. 

1. Click the Start From Beginning command on the Quick Access Toolbar to 

see your presentation. 
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2. The presentation will appear in full-screen mode. 

3. You can advance to the next slide by clicking your mouse or pressing 

the spacebar on your keyboard. You can also use the arrow keys on your 

keyboard to move forward or backward through the presentation. 

4. Press the Esc key to exit presentation mode. 

You can also press the F5 key at the top of your keyboard to start a presentation. 

Customizing slides 

To change the slide size: 

By default, all slides in PowerPoint 2013 use a 16-by-9—or widescreen—aspect ratio. 

You might know that widescreen TVs also use the 16-by-9 aspect ratio. Widescreen slides 

will work best with widescreen monitors and projectors. However, if you need your 

presentation to fit a 4-by-3 screen, it's easy to change the slide size to fit. 

 To change the slide size, select the Design tab, then click the Slide 

Size command. Choose the desired slide size from the menu that appears, or 

click Custom Slide Size for more options. 
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To format the slide background: 

By default, all slides in your presentation use a white background. It's easy to change the 

background style for some or all of your slides. Backgrounds can have 

a solid, gradient, pattern, or picture fill. 

1. Select the Design tab, then click the Format Background command. 

 

2. The Format Background pane will appear on the right. Select the desired 

fill options. In our example, we'll use a Solid fill with a light gold color. 
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3. The background style of the selected slide will update. 

4. If you want, you can click Apply to All to apply the same background style 

to all slides in your presentation. 
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To apply a theme: 

A theme is a predefined combination of colors, fonts, and effects that can quickly change 

the look and feel of your entire slide show. Different themes also use different slide 

layouts, which can change the arrangement of your existing placeholders. We'll talk more 

about themes later in our Applying Themes lesson. 

1. Select the Design tab on the Ribbon, then click the More drop-down arrow 

to see all of the available themes. 

 

2. Select the desired theme. 

http://www.gcflearnfree.org/powerpoint/applying-themes/1/
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3. The theme will be applied to your entire presentation. 

 

Try applying a few themes to your presentation. Some themes will work better than others, 

depending on your content. 

Challenge 

1. Open our practice presentation. 

https://media.gcflearnfree.org/content/5c0923ae77c0500354728517_12_06_2018/powerpoint_slidebasics_practice.pptx
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2. Change the theme of the presentation. 

3. Delete slide 7. This slide should be blank. 

4. Add a new slide with the Title and Content layout to the end of the 

presentation. 

5. In the Title placeholder, type Adoption Event Dates. 

6. Select the Content placeholder and delete it. 

7. Insert a text box and type July 17, 2017 inside it. 

8. Change the slide size to Standard (4:3). A dialog box will appear asking if 

you want to maximize or ensure fit. Choose Ensure Fit. 

9. When you're finished, your presentation should look something like this: 
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Presenting Your Slide Show 

Once your slide show is complete, you'll need to learn how to present it to an 

audience. PowerPoint offers several tools and features to help make your presentation 

smooth, engaging, and professional. 

Optional: Download our practice presentation. 

Presenting a slide show 

Before presenting your slide show, you'll need to think about the type 

of equipment that will be available for your presentation. Many presenters 

use projectors during presentations, so you might want to consider using one as well. This 

allows you to control and preview slides on one monitor while presenting them to an 

audience on another screen. 

To start a slide show: 

There are several ways you can begin your presentation: 

 Click the Start From Beginning command on the Quick Access Toolbar, 

or press the F5 key at the top of your keyboard. The presentation will appear 

in full-screen mode. 

 

https://media.gcflearnfree.org/content/5c092b7477c0500354728523_12_06_2018/powerpoint_presenting_practice.pptx
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 Select the Slide Show view command at the bottom of the PowerPoint 

window to begin a presentation from the current slide. 

 

 Go to the Slide Show tab on the Ribbon to access additional options. From 

here, you can start the presentation from the current slide and 

access advanced presentation options. 

 

To advance and reverse slides: 

You can advance to the next slide by clicking your mouse or pressing the spacebar on 

your keyboard. You can also use the arrow keys on your keyboard to move forward or 

backward through the presentation. 

You can also hover your mouse over the bottom-left and click the arrows to move forward 

or backward. 
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To stop a slide show: 

You can exit presentation mode by pressing the Esc key on your keyboard. You can also 

click the Slide Show Options button in the bottom-left and select End Show. 

 

The presentation will also end after the last slide. You can click the mouse or press the 

spacebar to return to Normal view. 
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Presentation tools and features 

PowerPoint provides convenient tools you can use while presenting your slide show. 

For example, you can change your mouse pointer to a pen or highlighter to draw attention 

to items in your slides. In addition, you can jump around to slides in your presentation or 

access other programs from your taskbar if needed. 

To show the taskbar: 

Sometimes you may need to access the Internet or other files and programs on your 

computer during your presentation. PowerPoint allows you to access your taskbar without 

ending the presentation. 

1. Locate and select the Slide Options button in the bottom-left corner. 

2. Select Screen, then click Show Taskbar. 
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3. Your taskbar will appear. Choose a program you want to open, like a web 

browser. When you're done, close the window or click the PowerPoint icon 

on the taskbar to return to the presentation. 
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Slide options 

You can also access any of the menu items above by right-clicking anywhere on the screen 

during your slide show. 

 

To skip to a nonadjacent slide: 

You can jump to slides out of order if needed. 

1. Locate and select the See All Slides button in the bottom-left corner. 

 

2. Thumbnail versions of each slide will appear. Select the slide you want to 

jump to. 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 197       
   

 

3. The selected slide will appear. 

To access drawing tools: 

Your mouse pointer can act as pen or highlighter to draw attention to items in your slides. 

1. Locate and select the Pen Tools button in the bottom-left corner. 

2. Select Pen or Highlighter based on your preference. You can also choose a 

different color from the menu. 
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3. Click and drag the mouse to mark your slides. You can also press Ctrl+P on 

your keyboard to access the pen tool while presenting your slide show. 

 

You can also use the laser pointer feature to draw attention to certain parts of your slide. 

Unlike the pen and highlighter, the laser pointer will not leave markings on your slides. To 

use the laser pointer, select it from Pen Tools, or press and hold the Ctrl key and the left 

mouse button. 
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To erase ink markings: 

1. Locate and select the Pen Tools button in the bottom-left corner. 

2. Select Eraser to erase individual ink markings, or select Erase All Ink on 

Slide to erase all markings. 

 

When you end a slide show, you'll also have the option to Keep or Discard any ink 

annotations made during your presentation. If you keep ink markings, they'll appear 

as objects on your slides in Normal view. 
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Presenter view 

If you're presenting your slide show with a second display—like a projector—you can 

use Presenter view. Presenter view gives you access to a special set of controls on your 

screen that the audience won't see, allowing you to easily reference slide notes, preview 

the upcoming slide, and much more. 

To access Presenter view: 

Start your slide show as you normally would, then click the Slide Options button and 

select Presenter View. You can also press Alt+F5 on your keyboard to start the slide show 

in Presenter view. 

 

Click the buttons in the interactive below to learn more about using Presenter view. 
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Slide show setup options 

PowerPoint has various options for setting up and playing a slide show. For example, you 

can set up an unattended presentation that can be displayed at a kiosk and make your slide 

show repeat with continuous looping. 

To access slide show setup options: 

1. Select the Slide Show tab, then click the Set Up Slide Show command. 

 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 202       
   

2. The Set Up Show dialog box will appear. From here, you can select the 

desired options for your presentation. 

Click the buttons in the interactive below to learn about various options for setting up and 

playing a slide show. 

 

Multiple Monitors 

If you have more than one monitor, you can choose which one to display the slide show 

on. It's usually best to leave this setting on Automatic. 
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To advance slides automatically, you'll need to customize the slide timing on 

the Transitions tab. Review our lesson on Applying Transitions to learn how. 

 

 

Tables 

Tables are another tool you can use to display information in PowerPoint. A table is a grid 

of cells arranged in rows and columns. Tables are useful for various tasks, including 

presenting text information and numerical data. You can even customize tables to fit your 

presentation. 

Optional: Download our practice presentation. 

To insert a table: 

1. From the Insert tab, click the Table command. 

2. Hover the mouse over the grid of squares to select the desired number 

of columns and rows in the table. In our example, we'll insert a table with six 

rows and six columns (6x6). 

http://www.gcflearnfree.org/powerpoint/applying-transitions/1/
https://media.gcflearnfree.org/content/5c0934d877c0500354728537_12_06_2018/powerpoint_tables_practice.pptx
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3. The table will appear on the currently selected slide. In our example, that's 

slide 3. 

4. Click anywhere in the table and begin typing to add text. You can also use 

the Tab key or the arrow keys on your keyboard to navigate through the 

table. 
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You can also insert a table by clicking the Insert Table command in a placeholder. 

 

Modifying tables 

PowerPoint includes several options for customizing tables, 

including moving and resizing, as well as adding rows and columns. 
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To move a table: 

 Click and drag the edge of a table to move it to a new location on a slide. 

 

To resize a table: 

 Click and drag the sizing handles until the table is the desired size. 
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To add a row or column: 

1. Click a cell adjacent to the location where you want to add a row or column. 

In our example, we'll select the cell that says Mystery. 

 

2. Click the Layout tab on the right side of the Ribbon. 

3. Locate the Rows & Columns group. If you want to insert a new row, select 

either Insert Above or Insert Below. If you want to insert a new column, 

select either Insert Left or Insert Right. 

 

4. The new row or column will appear. 
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To delete a row or column: 

1. Select the desired row or column. In our example, we'll select the empty 

row at the bottom of the table. 

 

2. From the Layout tab in the Rows & Columns group, click 

the Delete command, then select Delete Rows or Delete Columns from the 

menu. 
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3. The selected row or column will be deleted. 

 

You can also access the Insert and Delete commands by right-clicking a table. 
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To delete a table: 

 Click the edge of the table you want to delete, then press 

the Backspace or Delete key on your keyboard. 

Modifying tables with the Layout tab 

When you select a table, the Design and Layout tabs will appear on the right side of the 

Ribbon. You can make a variety of changes to a table using the commands on 

the Layout tab. 

Click the buttons in the interactive below to learn about the different commands on the 

Layout tab. 
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Text Direction 

Changing the text direction can add style to your table. It can also help to save space if 

you need to fit more columns in your table. 

Customizing tables 

PowerPoint makes it easy to change the look and feel of your tables. For example, you can 

quickly apply different table styles and customize the table borders. 

To apply a table style: 

1. Select any cell in your table, then click the Design tab on the right side of 

the Ribbon. 

2. Locate the Table Styles group, then click the More drop-down arrow to see 

available table styles. 

 

3. Select the desired style. 
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4. The selected table style will be applied. 
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To change table style options: 

You can turn various options on or off to change the appearance of the table. There are 

several options: Header Row, Total Row, Banded Rows, First Column, Last Column, 

and Banded Columns. 

1. Select any cell in your table. 

2. From the Design tab, check or uncheck the desired options in the Table 

Style Options group. 

 

These options can affect your table style in various ways, depending on the type of content 

in your table. You may need to experiment with a few options to find the exact style you 

want. 

To add borders to a table: 

You can add borders to help define different sections of a table. Certain table styles may 

include borders automatically, but it's easy to add them manually or customize them. You 

can control the border weight, color, and line style for some or all of a table. 
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1. Select the cells where you want to add borders. In our example, we'll 

select every cell in our table. 

2. From the Design tab, select the desired Line Style, Line Weight, and Pen 

Color. 

 

3. Click the Borders drop-down arrow, then select the desired border type. 

 

4. The border will be added to the selected cells. 
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5. To remove borders, select the desired cells, click the Borders command, 

and select No Border. 

Charts 

A Chart is a tool you can use to communicate data graphically. Including a chart 

in a presentation allows your audience to see the meaning behind the numbers, which 

makes it easy to visualize comparisons and trends. 

Optional: Download our practice presentation for this lesson. 

Types of charts 

PowerPoint has several types of charts, allowing you to choose the one that best fits your 

data. To use charts effectively, you'll need to understand how different charts are used. 

Click the arrows in the slideshow below to learn more about the types of charts in 

PowerPoint. 

https://media.gcflearnfree.org/content/5c09350277c0500354728539_12_06_2018/powerpoint_charts_practice.pptx
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PowerPoint has a variety of chart types, each with its own advantages. 

Click the arrows to see some of the different types of charts available in 

PowerPoint. 
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Column charts use vertical bars to represent data. They can work with 

many different types of data, but they're most frequently used for 

comparing information. 

 

Line charts are ideal for showing trends. The data points are connected 

with lines, making it easy to see whether values are increasing or 

decreasing over time. 

 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 218       
   

Pie charts make it easy to compare proportions. Each value is shown as 

a slice of the pie, so it's easy to see which values make up the percentage 

of a whole. 

  

Bar charts work just like column charts, but they use horizontal bars 

instead of vertical bars. 

  



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 219       
   

Area charts are similar to line charts, except the areas under the lines are 

filled in. 

 

Surface charts allow you to display data across a 3D landscape. They 

work best with large data sets, allowing you to see a variety of 

information at the same time. 
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Identifying the parts of a chart 

In addition to chart types, you'll need to understand how to read a chart. Charts contain 

several different elements-or parts-that can help you interpret data. 

Click the buttons in the interactive below to learn about the different parts of a chart. 

 

Legend 

The legend identifies which data series each color on the chart represents. In this example, 

the legend identifies the different months in the chart. 
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Inserting charts 

PowerPoint uses a spreadsheet as a placeholder for entering chart data, much like Excel. 

The process of entering data is fairly simple, but if you are unfamiliar with Excel you might 

want to review our Excel Cell Basics lesson. 

To insert a chart: 

1. Select the Insert tab, then click the Chart command in 

the Illustrations group. 

 

2. A dialog box will appear. Select a category from the left pane, and review 

the charts that appear in the right pane. 

3. Select the desired chart, then click OK. 

http://www.gcflearnfree.org/excel/cell-basics/1/
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4. A chart and spreadsheet will appear. The data that appears in the spreadsheet 

is placeholder source data you will replace with your own information. 

The source data is used to create the chart. 
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5. Enter data into the worksheet. 

 

6. Only the data enclosed by the blue lines will appear in the chart, but this area 

will expand automatically as you continue to type. 

 

7. When you're done, click X to close the spreadsheet. 
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8. The chart will be completed. 

 

You can edit the chart data at any time by selecting your chart and clicking the Edit 

Data command on the Design tab. 
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You can also click the Insert Chart command in a placeholder to insert a new chart. 

 

Creating charts with existing Excel data 

If you already have data in an existing Excel file you want to use for a chart, you can 

transfer the data by copying and pasting it. Just open the spreadsheet in Excel, select and 

copy the desired data, and paste it into the source data area for your chart. 

You can also embed an existing Excel chart into your PowerPoint presentation. This may 

be useful when you know you'll need to update the data in your Excel file and want the 

chart to automatically update whenever the Excel data is changed. 

Read our guide on Embedding an Excel Chart for more information. 

Modifying charts with chart tools 

There are many other ways to customize and organize your charts. For example, 

PowerPoint allows you to change the chart type, rearrange a chart's data, and even change 

the layout and style of a chart. 

https://edu.gcfglobal.org/en/powerpoint2013/embedding-an-excel-chart/1/
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To change the chart type: 

If you find that your data isn't working with a certain chart, it's easy to switch to a 

new chart type. In our example, we'll change our chart from a column chart to a line chart. 

1. Select the chart you want to change. The Design tab will appear on the right 

side of the Ribbon. 

 

2. From the Design tab, click the Change Chart Type command. 

 

3. A dialog box will appear. Select the desired chart type, then click OK. 
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4. The new chart type will appear. 

 

To switch row and column data: 

Sometimes you may want to change the way charts group your data. For example, in the 

chart below the book sales data is grouped by genre, with lines for each month. However, 
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we could switch the rows and columns so the chart will group the data by month, with 

lines for each genre. In both cases, the chart contains the same data; it's just organized 

differently. 

1. Select the chart you want to modify. The Design tab will appear. 

2. From the Design tab, select the Edit Data command in the Data group. 

 

3. Click the chart again, then select the Switch Row/Column command in 

the Data group. 

 

4. The rows and columns will be switched. In our example, the data is now 

grouped by month, with lines for each genre. 
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We've noticed that when numerical data has been entered in the first column of the 

spreadsheet, switching rows and columns may cause unexpected results. One solution is 

to type an apostrophe before each number, which tells the spreadsheet to format it 

as text instead of a numerical value. For example, the year 2016 would be entered as '2016. 

To change the chart layout: 

Predefined chart layouts allow you to modify chart elements—including chart 

titles, legends, and data labels—to make your chart easier to read. 

1. Select the chart you want to modify. The Design tab will appear. 

2. From the Design tab, click the Quick Layout command. 

 

3. Select the desired predefined layout from the menu that appears. 
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4. The chart will update to reflect the new layout. 

 

To change a chart element (like the chart title), click the element and begin typing. 
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To change the chart style: 

Chart styles allow you to quickly modify the look and feel of your chart. 

1. Select the chart you want to modify. The Design tab will appear. 

2. From the Design tab, click the More drop-down arrow in the Chart 

Styles group. 

 

3. Select the desired style from the menu that appears. 
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4. The chart will appear in the selected style. 

 

You can also use the chart formatting shortcut buttons to quickly add chart elements, 

change the chart style, and filter the chart data. 
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UNIT – IV 

MS EXCEL AN INTRODUCTION 

AN INTRODUCTION TO MS EXCEL 

MS Excel is a commonly used Microsoft Office application. It is a spreadsheet 

program which is used to save and analyse numerical data. 

Important features of MS Excel, along with an overview of how to use the program, 

its benefits and other important elements. A few sample MS Excel question and answers 

are also given further below in this article for the reference of Government exam aspirants.  

Basics of MS Excel 

MS Excel is a spreadsheet program where one can record data in the form of tables. 

It is easy to analyse data in an Excel spreadsheet. The image given below represents how 

an Excel spreadsheet looks like: 
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To open MS Excel 

To open MS Excel on your computer, follow the steps given below: 

 Click on Start 

 Then All Programs 

 Next step is to click on MS Office 

 Then finally, choose the MS-Excel option 

Alternatively, you can also click on the Start button and type MS Excel in the search option 

available. 

A Cell 

A spreadsheet is in the form of a table comprising rows and columns. The 

rectangular box at the intersection point between rows and columns forms a cell. Given 

below is an image of a cell: 

Cell Address 

The cell address is the name by which is cell can be addressed. For example, if row 

7 is interested in column G, then the cell address is G7.  

FEATURES OF MS EXCEL 

Various editing and formatting can be done on an Excel spreadsheet. Discussed 

below are the various features of MS Excel.  

The image below shows the composition of features in MS Excel: 
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 Home 

 Comprises options like font size, font styles, font colour, background colour, 

alignment, formatting options and styles, insertion and deletion of cells and 

editing options 

 Insert 

 Comprises options like table format and style, inserting images and figures, 

adding graphs, charts and sparklines, header and footer option, equation and 

symbols 

 Page Layout 

 Themes, orientation and page setup options are available under the page 

layout option 

 Formulas 

 Since tables with a large amount of data can be created in MS excel, under 

this feature, you can add formulas to your table and get quicker solutions  

 Data 

 Adding external data (from the web), filtering options and data tools are 

available under this category 
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 Review 

 Proofreading can be done for an excel sheet (like spell check) in the review 

category and a reader can add comments in this part  

 View 

 Different views in which we want the spreadsheet to be displayed can be 

edited here. Options to zoom in and out and pane arrangement are available 

under this category 

BENEFITS OF USING MS EXCEL 

MS Excel is widely used for various purposes because the data is easy to save, and 

information can be added and removed without any discomfort and less hard work. 

Given below are a few important benefits of using MS Excel: 

 Easy To Store Data: Since there is no limit to the amount of information that can 

be saved in a spreadsheet, MS Excel is widely used to save data or to analyse data. 

Filtering information in Excel is easy and convenient. 

 Easy To Recover Data: If the information is written on a piece of paper, finding it 

may take longer, however, this is not the case with excel spreadsheets. Finding and 

recovering data is easy. 

 Application of Mathematical Formulas: Doing calculations has become easier 

and less time-taking with the formulas option in MS excel 
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 More Secure: These spreadsheets can be password secured in a laptop or personal 

computer and the probability of losing them is way lesser in comparison to data 

written in registers or piece of paper. 

 Data at One Place: Earlier, data was to be kept in different files and registers when 

the paperwork was done. Now, this has become convenient as more than one 

worksheet can be added in a single MS Excel file. 

 Neater and Clearer Visibility of Information: When the data is saved in the form 

of a table, analysing it becomes easier. Thus, information is a spreadsheet that is 

more readable and understandable. 

MS Excel – Points To Remember 

There are certain things which one must know with respect to MS Excel, its 

applications and usage: 

 An MS Excel file is saved with an extension of .xls 

 Companies with large staff and workers use MS Excel as saving employee 

information becomes easier 

 Excel spreadsheets are also used in hospitals where the information of patients can 

be saved more easily and can be removed conveniently once their medical history 

is cleared 

 The sheet on which you work is called a Worksheet 

 Multiple worksheets can be added in a single Excel file 
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 This is a data processing application 

Aspirants can also prepare themselves by regularly solving mock tests and question papers 

to analyse the standard of examination and excelling in them. Refer to the links below, for 

the same: 

INTRODUCTION TO EXCEL SPREADSHEET 

A spreadsheet is a computer application that is designed to add, display, analyze, 

organize, and manipulate data arranged in rows and columns. It is the most popular 

application for accounting, analytics, data presentation, etc. Or in other words, 

spreadsheets are scalable grid-based files that are used to organize data and perform 

calculations. People all across the world use spreadsheets to create tables for personal 

and business usage. You can also use the tool’s features and formulas to help you make 

sense of your data. You could, for example, track data in a spreadsheet and see sums, 

differences, multiplication, division, and fill dates automatically, among other things. 

Microsoft Excel, Google sheets, Apache open office, LibreOffice, etc are some 

spreadsheet software. Among all these software, Microsoft Excel is the most commonly 

used spreadsheet tool and it is available for Windows, macOS, Android, etc.  

A Collection of spreadsheets is known as a workbook. Every Excel file is called a 

workbook. Every time when you start a new project in Excel, you’ll need to create a new 

workbook. There are several methods for getting started with an Excel workbook. To 

create a new worksheet or access an existing one, you can either start from scratch or 

utilize a pre-designed template. 
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A Single Excel worksheet is a tabular spreadsheet that consists of a matrix of 

rectangular cells grouped in rows and columns. It has a total of 1,048,576 rows and 

16,384 columns, resulting in 17,179,869,184 cells on a single page of a Microsoft Excel 

spreadsheet where you may write, modify, and manage your data. 

In the same way as a file or a book is made up of one or more worksheets that 

contain various types of related data, an Excel workbook is made up of one or more 

worksheets. You can also create and save an endless number of worksheets. The major 

purpose is to collect all relevant data in one place, but in many categories (worksheet). 

FEATURE OF SPREADSHEET 

As we know that there are so many spreadsheet applications available in the 

market. So these applications provide the following basic features: 

1. Rows and columns: Rows and columns are two distinct features in a spreadsheet that 

come together to make a cell, a range, or a table. In general, columns are the vertical 

portion of an excel worksheet, and there can be 256 of them in a worksheet, whereas rows 

are the horizontal portion, and there can be 1048576 of them. 
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The color light green is used to highlight Row 3 while the color green is used to highlight 

Column B. Each column has 1048576 rows and each row has 256 columns. 

2. Formulas: In spreadsheets, formulas process data automatically. It takes data from the 

specified area of the spreadsheet as input then processes that data, and then displays the 

output into the new area of the spreadsheet according to where the formula is written. In 

Excel, we can use formulas simply by typing “=Formula Name(Arguments)” to use 

predefined Excel formulas. When you write the first few characters of any formula, Excel 

displays a drop-down menu of formulas that match that character sequence. Some of the 

commonly used formulas are: 

 =SUM(Arg1: Arg2): It is used to find the sum of all the numeric data specified in the 

given range of numbers. 

 =COUNT(Arg1: Arg2):  It is used to count all the number of cells(it will count only 

number) specified in the given range of numbers. 
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 =MAX(Arg1: Arg2): It is used to find the maximum number from the given range of 

numbers. 

 =MIN(Arg1: Arg2): It is used to find the minimum number from the given range of 

numbers. 

 =TODAY(): It is used to find today’s date. 

 =SQRT(Arg1): It is used to find the square root of the specified cell. 

For example, you can use the formula to find the average of the integers in column C 

from row 2 to row 7: 

= AVERAGE(D2:D7) 

The range of values on which you want to average is defined by D2:D6. The formula is 

located near the name field on the formula tab. 
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We wrote =AVERAGE(D2:D6) in cell D9, therefore the average becomes (2 + 3 + 4 + 5 

+ 6 + 7)/6 = 27/6 = 4.5. So you can quickly create a workbook, work on it, browse through 

it, and save it in this manner. 

3. Function: In spreadsheets, the function uses a specified formula on the input and 

generates output. Or in other words, functions are created to perform complicated math 

problems in spreadsheets without using actual formulas. For example, you want to find 

the total of the numeric data present in the column then use the SUM function instead of 

adding all the values present in the column.  

4. Text Manipulation: The spreadsheet provides various types of commands to 

manipulate the data present in it.  

5. Pivot Tables: It is the most commonly used feature of the spreadsheet. Using this table 

users can organize, group, total, or sort data using the toolbar. Or in other words, pivot 

tables are used to summarize lots of data. It converts tons of data into a few rows and 

columns. 

USE OF SPREADSHEETS 

The use of Spreadsheets is endless. It is generally used with anything that contains 

numbers. Some of the common use of spreadsheets are: 

 Finance: Spreadsheets are used for financial data like it is used for checking account 

information, taxes, transaction, billing, budgets, etc. 

 Forms: Spreadsheet is used to create form templates to manage performance review, 

timesheets, surveys, etc. 
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 School and colleges: Spreadsheets are most commonly used in schools and colleges 

to manage student’s data like their attendance, grades, etc. 

 Lists: Spreadsheets are also used to create lists like grocery lists, to-do lists, contact 

detail, etc. 

 Hotels: Spreadsheets are also used in hotels to manage the data of their customers 

like their personal information, room numbers, check-in date, check-out date, etc. 

COMPONENTS OF SPREADSHEETS 

The basic components of spreadsheets are: 

 

1. TitleBar: The title bar displays the name of the spreadsheet and application.  

2. Toolbar: It displays all the options or commands available in Excel for use.   

3. NameBox: It displays the address of the current or active cell. 
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4. Formula Bar: It is used to display the data entered by us in the active cell. Also, this 

bar is used to apply formulas to the data of the spreadsheet.  

5. Column Headings: Every excel spreadsheet contains 256 columns and each column 

present in the spreadsheet is named by letters or a combination of letters.  

6. Row Headings: Every excel spreadsheet contains 65,536 rows and each row present 

in the spreadsheet is named by a number. 

7. Cell: In a spreadsheet, everything like a numeric value, functions, expressions, etc., is 

recorded in the cell. Or we can say that an intersection of rows and columns is known as 

a cell. Every cell has its own name or address according to its column and rows and when 

the cursor is present on the first cell then that cell is known as an active cell. 

8. Cell referring: A cell reference, also known as a cell address, is a way for describing 

a cell on a worksheet that combines a column letter and a row number. We can refer to 

any cell on the worksheet using cell references (in excel formulae). As shown in the above 

image the cell in column A and row 1 is referred to as A1. Such notations can be used in 

any formula or to duplicate the value of one cell to another (by using = A1). 

9. Navigation buttons: A spreadsheet contains first, previous, next, and last navigation 

buttons. These buttons are used to move from one worksheet to another workbook.  

10. Sheet tabs: As we know that a workbook is a collection of worksheets. So this tab 

contains all the worksheets present in the workbook, by default it contains three 

worksheets but you can add more according to your requirement. 
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CREATE A NEW SPREADSHEET OR WORKBOOK 

To create a new spreadsheet follow the following steps: 

Step 1: Click on the top-left, Microsoft office button and a drop-down menu appear. 

Step 2: Now select New from the menu. 

 

 

Step 3: After selecting the New option a New Workbook dialogue box will appear and 

then in Create tab, click on the blank Document. 
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A new blank worksheet is created and is shown on your screen.  

Note: When you open MS Excel on your computer, it creates a new Workbook for you. 

Saving The Workbook  

In Excel we can save a workbook using the following steps: 

Step 1: Click on the top-left, Microsoft office button and we get a drop-down menu: 
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Step 2: Now Save or Save As are the options to save the workbook, so choose one. 

 Save As: To name the spreadsheet and then save it to a specific location. Select Save 

As if you wish to save the file for the first time, or if you want to save it with a new 

name. 

 Save: To save your work, select Save/ click ctrl + S if the file has already been named. 

So this is how you can save a workbook in Excel. 

Inserting text in Spreadsheet 

Excel consists of many rows and columns, each rectangular box in a row or column 

is referred to as a Cell. So, the combination of a column letter and a row number can be 

used to find a cell address on a worksheet or spreadsheet. We can refer to any cell in the 

worksheet using these addresses (in excel formulas). The name box on the top left(below 

the Home tab) displays the cell’s address whenever you click the cell. 

 

To insert the data into the cell follow the following steps: 

Step 1: Go to a cell and click on it 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 248       
   

Step 2: By typing something on the keyboard, you can insert your data (In that selected 

cell). 

 

Whatever text you type displays in the formula bar as well (for that cell). 

Edit/ Delete Cell Contents in the Spreadsheet 

To delete cell content follow the following steps: 

Step 1: To alter or delete the text in a cell, first select it.  

Step 2: Press the Backspace key on your keyboard to delete and correct text. 

Alternatively, hit the Delete key to delete the whole contents of a cell. You can also edit 

and delete text using the formula bar. Simply select the cell and move the pointer to the 

formula bar. 
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ENTERING, EDITING, AND MANAGING DATA 

ENTERING DATA 

You will begin building the workbook shown in Figure 1.1 by manually entering data 

into the worksheet. The following steps explain how the column headings in Row 2 are 

typed into the worksheet: 

1. Click cell location A2 on the worksheet. 

2. Type the word Month. 

3. Press the RIGHT ARROW key. This will enter the word into cell A2 and activate the 

next cell to the right. 

4. Type Unit Sales and press the RIGHT ARROW key. 

5. Repeat step 4 for the words Average Price and then again for Sales Dollars. 

Figure 1.15 shows how your worksheet should appear after you have typed the column 

headings into Row 2. Notice that the word Price in cell location C2 is not visible. This is 

because the column is too narrow to fit the entry you typed. We will examine formatting 

techniques to correct this problem in the next section. 
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Figure 1.15 Entering Column Headings into a Worksheet 

Column Headings 

It is critical to include column headings that accurately describe the data in each 

column of a worksheet. In professional environments, you will likely be sharing Excel 

workbooks with coworkers. Good column headings reduce the chance of someone 

misinterpreting the data contained in a worksheet, which could lead to costly errors 

depending on your career. 

1. Click cell location B3. 

2. Type the number 2670 and press the ENTER key. After you press the ENTER key, cell 

B4 will be activated. Using the ENTER key is an efficient way to enter data vertically 

down a column. 
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3. Enter the following numbers in cells B4 through 

B14: 2160, 515, 590, 1030, 2875, 2700, 900, 775, 1180, 1800, and 3560. 

4. Click cell location C3. 

5. Type the number 9.99 and press the ENTER key. 

6. Enter the following numbers in cells C4 through 

C14: 12.49, 14.99, 17.49, 14.99, 12.49, 9.99, 19.99, 19.99, 19.99, 17.49, and 14.99. 

7. Activate cell location D3. 

8. Type the number 26685 and press the ENTER key. 

9. Enter the following numbers in cells D4 through 

D14: 26937, 7701, 10269, 15405, 35916, 26937, 17958, 15708, 23562, 31416, 

and 53370. 

10. When finished, check that the data you entered matches Figure 1.16. 

Avoid Formatting Symbols When Entering Numbers 

When typing numbers into an Excel worksheet, it is best to avoid adding any 

formatting symbols such as dollar signs and commas. Although Excel allows you to add 

these symbols while typing numbers, it slows down the process of entering data. It is more 

efficient to use Excel’s formatting features to add these symbols to numbers after you type 

them into a worksheet. 

Data Entry 

It is very important to proofread your worksheet carefully, especially when you have 

entered numbers. Transposing numbers when entering data manually into a worksheet is a 
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common error. For example, the number 563 could be transposed to 536. Such errors can 

seriously compromise the integrity of your workbook. 

Figure 1.16 shows how your worksheet should appear after entering the data. Check your 

numbers carefully to make sure they are accurately entered into the worksheet. 

 

Figure 1.16  Completed Data Entry for Columns B, C, and D 
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EDITING DATA 

Data that has been entered in a cell can be changed by double clicking the cell location 

or using the Formula Bar. You may have noticed that as you were typing data into a cell 

location, the data you typed appeared in the Formula Bar. The Formula Bar can be used 

for entering data into cells as well as for editing data that already exists in a cell. The 

following steps provide an example of entering and then editing data that has been entered 

into a cell location: 

1. Click cell A15 in the Sheet1 worksheet. 

2. Type the abbreviation Tot and press the ENTER key. 

3. Click cell A15. 

4. Move the mouse pointer up to the Formula Bar. You will see the pointer turn into a 

cursor. Move the cursor to the end of the abbreviation Tot and left click. 

5. Type the letters al to complete the word Total. 

6. Click the checkmark to the left of the Formula Bar (see Figure 1.17). This will enter the 

change into the cell. 

7. Double click cell A15. 

8. Add a space after the word Total and type the word Sales. 

9. Press the ENTER key. 
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Figure 1.17 Using the Formula Bar to Edit and Enter Data 

Editing Data in a Cell 

 Activate the cell that is to be edited and press the F2 key on your keyboard. 

AUTO FILL 

The Auto Fill feature is a valuable tool when manually entering data into a 

worksheet. This feature has many uses, but it is most beneficial when you are entering data 
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in a defined sequence, such as the numbers 2, 4, 6, 8, and so on, or nonnumeric data such 

as the days of the week or months of the year. The following steps demonstrate how Auto 

Fill can be used to enter the months of the year in Column A: 

1. Click cell A3 in the Sheet1 worksheet. 

2. Type the word January and press the ENTER key. 

3. Activate cell A3 again. 

4. Move the mouse pointer to the lower right corner of cell A3. You will see a small 

square in this corner of the cell; this is called the Fill Handle (See Figure 1.18) When 

the mouse pointer gets close to the Fill Handle, the white block plus sign will turn into 

a black plus sign. 

 

 

 

 

 

 

 

 

Figure 1.18 Fill Handle 
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Left click and drag the Fill Handle to cell A14. Notice that the Auto Fill tip box indicates 

what month will be placed into each cell (see Figure 1.19). Release the left mouse button 

when the tip box reads “December.” 

 

Figure 1.19  Using Auto Fill to Enter the Months of the Year 

Once you release the left mouse button, all twelve months of the year should appear in the 

cell range A3:A14, as shown in Figure 1.20. You will also see the Auto Fill Options button. 

By clicking this button, you have several options for inserting data into a group of cells. 
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Figure 1.20 Auto Fill Options Button 

1. Click the Auto Fill Options button. 

2. Click the Copy Cells option. This will change the months in the range A4:A14 to 

January. 

3. Click the Auto Fill Options button again. 

4. Click the Fill Months option to return the months of the year to the cell range A4:A14. 

The Fill Series option will provide the same result. 



    
 

 

Manonmaniam Sundaranar University, Tirunelveli.             Directorate of Distance & Continuing Education            Page | 258       
   

DELETING DATA AND THE UNDO COMMAND 

There are several methods for removing data from a worksheet, a few of which are 

demonstrated here. With each method, you use the Undo command. This is a helpful 

command in the event you mistakenly remove data from your worksheet. The following 

steps demonstrate how you can delete data from a cell or range of cells: 

1. Click cell C2 by placing the mouse pointer over the cell and clicking the left mouse 

button. 

2. Press the DELETE key on your keyboard. This removes the contents of the cell. 

3. Highlight the range C3:C14 by placing the mouse pointer over cell C3. Then left click 

and drag the mouse pointer down to cell C14. 

4. Place the mouse pointer over the Fill Handle. You will see the white block plus sign 

change to a black plus sign. 

5. Click and drag the mouse pointer up to cell C3 (see Figure 1.21). Release the mouse 

button. The contents in the range C3:C14 will be removed. 
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Figure 1.21  Using Auto Fill to Delete Contents of Cell 

1. Click the Undo button in the Quick Access Toolbar (see Figure 1.2). This should 

replace the data in the range C3:C14. 

2. Click the Undo button again. This should replace the data in cell C2. 

Keyboard Shortcuts 

Undo Command 

 Hold down the CTRL key while pressing the letter Z on your keyboard. 

 Highlight the range C2:C14 by placing the mouse pointer over cell C2. Then left click 

and drag the mouse pointer down to cell C14. 
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 Click the Clear button in the Home tab of the Ribbon, which is next to the Cells group 

of commands (see Figure 1.22). This opens a drop-down menu that contains several 

options for removing or clearing data from a cell. Notice that you also have options for 

clearing just the formats in a cell or the hyperlinks in a cell. 

 Click the Clear All option. This removes the data in the cell range. 

 Click the Undo button. This replaces the data in the range C2:C14. 

Figure 1.22 Clear Command Drop-Down Menu 

ADJUSTING COLUMNS AND ROWS 

There are a few entries in the worksheet that appear cut off. For example, the last 

letter of the word September cannot be seen in cell A11. This is because the column is too 

narrow for this word. The columns and rows on an Excel worksheet can be adjusted to 
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accommodate the data that is being entered into a cell. The following steps explain how to 

adjust the column widths and row heights in a worksheet: 

1. Bring the mouse pointer between Column A and Column B in the Sheet1 worksheet, as 

shown in Figure 1.23. You will see the white block plus sign turn into double arrows. 

2. Click and drag the column to the right so the entire word September in cell A11 can be 

seen. As you drag the column, you will see the column width tip box. This box displays 

the number of characters that will fit into the column using the Calibri 11-point font 

which is the default setting for font/size. 

3. Release the left mouse button. 

 

Figure 1.23 Adjusting Column Widths 
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You may find that using the click-and-drag method is inefficient if you need to set a 

specific character width for one or more columns. Steps 1 through 6 illustrate a second 

method for adjusting column widths when using a specific number of characters: 

1. Click any cell location in Column A by moving the mouse pointer over a cell location 

and clicking the left mouse button. You can highlight cell locations in multiple columns 

if you are setting the same character width for more than one column. 

2. In the Home tab of the Ribbon, left click the Format button in the Cells group. 

3. Click the Column Width option from the drop-down menu. This will open the Column 

Width dialog box. 

4. Type the number 13 and click the OK button on the Column Width dialog box. This will 

set Column A to this character width (see Figure 1.24). 

5. Once again bring the mouse pointer between Column A and Column B so that the double 

arrow pointer displays and then double-click to activate AutoFit. This features adjusts 

the column width based on the longest entry in the column. 

6. Use the Column Width dialog box (step 6 above) to reset the width to 13. 
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Figure 1.24 Column Width Dialog Box 

Steps 1 through 4 demonstrate how to adjust row height, which is similar to adjusting 

column width: 

1. Click cell A15 by placing the mouse pointer over the cell and clicking the left mouse 

button. 

2. In the Home tab of the Ribbon, left click the Format button in the Cells group. 

3. Click the Row Height option from the drop-down menu. This will open the Row Height 

dialog box. 

4. Type the number 24 and click the OK button on the Row Height dialog box. This will 

set Row 15 to a height of 24 points. A point is equivalent to approximately 1/72 of an 

inch. This adjustment in row height was made to create space between the totals for this 

worksheet and the rest of the data. 
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Figure 1.25 shows the appearance of the worksheet after Column A and Row 15 are 

adjusted. 

 

Figure 1.25 GMW Sales Data with Column A and Row 15 Adjusted 

HIDING COLUMNS AND ROWS 

In addition to adjusting the columns and rows on a worksheet, you can also hide 

columns and rows. This is a useful technique for enhancing the visual appearance of a 

worksheet that contains data that is not necessary to display. These features will be 

demonstrated using the GMW Sales Data workbook. However, there is no need to have 
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hidden columns or rows for this worksheet. The use of these skills here will be for 

demonstration purposes only. 

1. Click cell C1 in the Sheet1 worksheet by placing the mouse pointer over the cell 

location and clicking the left mouse button. 

2. Click the Format button in the Home tab of the Ribbon. 

3. Place the mouse pointer over the Hide & Unhide option in the drop-down menu. This 

will open a submenu of options. 

4. Click the Hide Columns option in the submenu of options (see Figure 1.26). This will 

hide Column C. 

 

Figure 1.26 Hide & Unhide Submenu 

 

 

Figure 1.27 shows the workbook with Column C hidden in the Sheet1 worksheet. 

You can tell a column is hidden by the missing letter C. 
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Figure 1.27 Hidden Column 

To unhide a column, follow these steps: 

1. Highlight the range B1:D1 by activating cell B1 and clicking and dragging over to cell 

D1. 

2. Click the Format button in the Home tab of the Ribbon. 

3. Place the mouse pointer over the Hide & Unhide option in the drop-down menu. 

4. Click the Unhide Columns option in the submenu of options. Column C will now be 

visible on the worksheet. 

INSERTING COLUMNS AND ROWS 

Using Excel workbooks that have been created by others is a very efficient way to 

work because it eliminates the need to create data worksheets from scratch. However, 
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you may find that to accomplish your goals, you need to add additional columns or rows 

of data. In this case, you can insert blank columns or rows into a worksheet. The 

following steps demonstrate how to do this: 

1. Click cell C1 in the Sheet1 worksheet by placing the mouse pointer over the cell 

location and clicking the left mouse button. 

2. Click the down arrow on the Insert button in the Home tab of the Ribbon. 

 

3. Click the Insert Sheet Columns option from the drop-down menu. A blank 

column will be inserted to the left of Column C. The contents that were previously 

in Column C now appear in Column D. Note that columns are always inserted to 

the left of the activated cell. 
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4. Click cell A3 in the Sheet1 worksheet by placing the mouse pointer over the cell location 

and clicking the left mouse button. 

5. Click the down arrow on the Insert button in the Home tab of the Ribbon  

6. Click the Insert Sheet Rows option from the drop-down menu. A blank row will be 

inserted above Row 3. The contents that were previously in Row 3 now appear in Row 4. 

Note that rows are always inserted above the activated cell. 

MOVING DATA 

Once data are entered into a worksheet, you have the ability to move it to different 

locations. The following steps demonstrate how to move data to different locations on a 

worksheet: 

1. Highlight the range D2:D15 by activating cell D2 and clicking and dragging down to 

cell D15. 
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2. Bring the mouse pointer to the left edge of cell D2. You will see the white block plus 

sign change to cross arrows. This indicates that you can left click and drag the data to a 

new location. 

 

3. Left Click and drag the mouse pointer to cell C2. 

4. Release the left mouse button. The data now appears in Column C. 

5. Click the Undo button in the Quick Access Toolbar. This moves the data back to Column D. 

DELETING COLUMNS AND ROWS 

You may need to delete entire columns or rows of data from a worksheet. This need 

may arise if you need to remove either blank columns or rows from a worksheet or columns 

and rows that contain data. The methods for removing cell contents were covered earlier 

and can be used to delete unwanted data. However, if you do not want a blank row or 

column in your workbook, you can delete it using the following steps: 
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1. Click cell A3 by placing the mouse pointer over the cell location and clicking the left 

mouse button. 

2. Click the down arrow on the Delete button in the Cells group in the Home tab of the 

Ribbon. 

 

3. Click the Delete Sheet Rows option from the drop-down menu. This removes Row 3 and 

shifts all the data (below Row 2) in the worksheet up one row. 

4. Click cell C1 by placing the mouse pointer over the cell location and clicking the left 

mouse button. 

5. Click the down arrow on the Delete button in the Cells group in the Home tab of the 

Ribbon. 

6. Click the Delete Sheet Columns option from the drop-down menu (see Figure 1.31). 

This removes Column C and shifts all the data in the worksheet (to the right of Column B) 

over one column to the left. 

7. Save the changes to your workbook by clicking either the Save button on the Home 

ribbon; or by selecting the Save option from the File menu. 
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UNIT – V 

INTRODUCTION TO INTERNET 

HISTORY OF INTERNET  

The Internet is the most commonly used term in today’s world and plays a very 

important role in the everyday life of people. But there are many questions, answers to 

which people need to know. In this article, we shall help you find answers to these 

questions; discuss the evolution of the Internet, its usage, benefits, history and how the 

Internet works.  

In terms of Computer Awareness, the Internet is one of the most important topics in 

competitive exams. Thus, candidates preparing for exams like Banking, Insurance, SSC, 

etc. must read on to learn more about the Internet.  

Let us first answer a few of the most important questions which arise with regard to the 

Internet. 

INTERNET 

A global system of interconnected computers, using a standardised Internet Protocol 

suite for communication and sharing information is called the Internet. 

ISP 

ISP stands for Internet Service Provider. This helps in providing direct access for 

using the internet from your office or home, connected through landlines. With the 

introduction of Wi-fi and broadband, connecting to the Internet has become wireless. 
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World Wide Web 

World Wide Web or ‘www’ is a collection of webpages which can easily be 

published on the Internet and read by millions of its users. To know the difference between 

World Wide Web (www) and Internet, candidates can visit the linked article. 

IP address 

The Internet Protocol address is a numerical identification code assigned for any 

device connected to a network. It acts as an identification interface for Internet users. 

Web Browser 

A Web browser is a software application for accessing the information on the World 

Wide Web. The commonly used web browsers include Google Chrome, Internet Explorer, 

Mozilla Firefox, etc. 

EVOLUTION OF THE INTERNET 

The Internet completely revolutionised communication and technology across the 

Globe. Initially, computerised devices were only used for large industries but later its usage 

increased massively. 

It is also mandatory for people to know that it is not possible for a single person to 

develop something as broad and wide as the Internet all by himself/herself. It was a 

combined effort of multiple researchers and programmers that the Internet was discovered.  

https://byjus.com/free-ias-prep/difference-between-www-and-internet/
https://byjus.com/free-ias-prep/difference-between-www-and-internet/
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Given below are a few important points which played an extremely important role in the 

development of the Internet and making it one of the most widely used resources across 

the world.  

 The first development was the introduction of host-to-host network interactions. 

This was first observed in ARPANET in 1969. It was developed by Advanced 

Research Projects Agency (APRA) of the Department of Defence, U.S. It was one 

of the first general usage of computer networks. 

 Next step was commercialising the usage and making the transistors and 

transmitters fit in smaller devices for convenient Internet usage for the general 

public. This was introduced in the 1970s 

 Moving forward, satellites and wireless communication was the main target. 

Defence Advanced Research Projects Agency (formerly ARPA), supported 

satellite-based radio packets for mobile usage of networks 

 The next was the development of Transmission Control Protocol (TCP). This 

enabled different machines and networks across the world to assemble data packets. 

It was in the 1980s that the TCP/IP approach was adapted by researchers and 

technologists, following the footsteps of the U.S. Department of Defence 

 With the introduction of personal computers, the demand for commercial Internet 

usage increased. This was the time when Ethernet and other Local Area Networks 

cam in the foreground 
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 In 1993, the web browser was introduced, which followed the point-and-click 

approach and is now a widely used operation for Internet users 

 The late 1990s was the time when thousands of Internet Service Providers has taken 

up the market and most of them were from the U.S. 

 And then the 21st century brought in an amalgamation of technology and wireless 

Internet accessibility for its users. Wherein, wireless broadband services came in as 

a boon for Internet users 

Amid all these developments which were made, a lot of successes and failures came in but 

today, the Internet is one such commodity which has made lives easier and brought in a 

wider pace for development across the globe. 

WAYS TO CONNECT TO INTERNET 

The different ways in which one can connect to the Internet are discussed below in brief: 

 Dial-Up – In such connections, users are required to link their phone line to a 

computer to access the Internet. Under this connection, the user cannot make or 

receive phone calls through tier home phone service 

 Broadband – Provided either through cable or phone companies, Broadband is a 

high-speed internet connection which is widely used today 

 Wireless Connection – Wi-fi and Mobile service providers fall under this category. 

Internet connectivity is made via radio waves and the Internet can be connected 
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anywhere, irrespective of the location. Given below are a few examples of wireless 

connection: 

 Wi-fi – Wireless Fidelity or wi-fi allows high-speed internet connectivity 

without the use of wires 

 Mobile Phones – All smartphones are now equipped with an option for 

Internet connectivity which can be availed using Internet vouchers and 

packs. No external connection or wire is required for these 

 Satellite – Where broadband connections are unavailable, satellites are used 

for wireless Internet connectivity 

 Integrated Services Digital Network – ISDN allows users to sent audio or 

video data using telephone lines 

INTERNET CONNECTION PROTOCOLS 

Protocols are a set of rules that help in governing the way in which any particular 

body or technology works. 

Internet Connection Protocols can be divided into three major types: 

 TCP/IP Network Model – Transmission Control Protocol (TCP) and Internet 

Protocol (IP) are the most widely used protocols for connecting networks. It divides 

any message into a series of packets which are sent from source to destination 

 File Transfer Protocol – Program files, multimedia files, text files, documents, etc. 

can be transferred from one device to another, using FTP 
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 Hypertext Transfer Protocol – Used for transferring a hypertext from one device 

to two or more devices. HTML tags are used for creating links and these links may 

be in the form of text or images 

PROS AND CONS OF USING THE INTERNET 

Intentionally or unintentionally, Internet usage is a part in the day to day lives of 

every individual. The Internet has made lives easy and comfortable, but at the same time 

made human being dependable for the smallest or biggest of information. Discussed below 

are the uses of the internet, along with a few cons that it brings along. 

Pros of Internet 

 Easy Access to Information – Information on anything and everything are 

available online. The Internet makes it convenient to learn about new things at any 

point in time and get details on various subjects, irrespective of time and place 

 Platform for Online Education – With the advanced technology, even students 

and adults wish to learn new things and gaining knowledge at various online portals 

has become more accessible 

 Job Hunting – Employers can look for employees on the internet and the job 

seekers can apply online for jobs using the Internet 

 Platform to become an Entrepreneur – Today, thousands of people have started 

their own websites and getting good business and users/customers by making their 
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own websites and selling products or services. This has become accessible due to 

Internet connectivity 

 Visual and Graphical Representation of Things – Various researches have shown 

that a person tends to get more engaged with a graphical representation of things. 

Internet has made this facility also convenient for both user and creator  

 Reduced the parameter of Distance – Social media has reduced the distance 

between people as communication has become much easier because of Internet 

connection   

With the Internet being an extremely essential part of daily life, it is important that a person 

is well aware of the disadvantages of the Internet and its excess usage. 

Cons of Internet 

 Dependency – The dependency of people for looking things and information online 

has increased massively since the introduction of Internet and its easy access 

 Cyber Crime – People do not just use internet for learning purposes, cybercrime 

has also been at a distinctive high because of effortless availability of resources 

 Distraction – People can easily find online games, interesting information, etc. 

online which may be a cause of distraction for may 

 Bullying and Trolls – Online platforms are being used for unethical practises like 

bullying people and trolling them 

All the information provided in this article regarding the Internet will bring in a broader 

perspective of connectivity, networks and protocols which are necessary for Internet usage. 
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Analysing and studying the information given here shall prove to be highly useful for 

people belonging to all age groups.  

Computer Virus 

A Computer virus is a kind of malicious computer program, which when executed, 

replicates itself and inserts its own code. When the replication is done, this code infects the 

other files and program present on your system.  

These computer viruses are present in various types and each of them can infect a 

device in a different manner.  

Apart from being aware of what a computer virus is, this topic is even important for 

candidates preparing for Government exams. Major competitive exams in the country 

comprise Computer Knowledge as an integral part of the syllabus and questions based on 

virus and anti-virus can also be expected in these exams.  

Thus, to excel in the upcoming Govt exams, aspirants must go through this article 

in detail and carefully study the different types of viruses. 

A Computer virus is a program which can harm our device and files and infect them 

for no further use. When a virus program is executed, it replicates itself by modifying other 

computer programs and instead enters its own coding. This code infects a file or program 

and if it spreads massively, it may ultimately result in crashing of the device.  

Across the world, Computer viruses are a great issue of concern as they can cause billions 

of dollars’ worth harm to the economy each year.  

https://byjus.com/govt-exams/computer-knowledge/
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Since the computer virus only hits the programming of the device, it is not visible. But 

there are certain indications which can help you analyse that a device is virus-hit. Given 

below are such signs which may help you identify computer viruses: 

 Speed of the System – In case a virus is completely executed into your device, the 

time taken to open applications may become longer and the entire system processing 

may start working slowly 

 Pop-up Windows – One may start getting too many pop up windows on their screen 

which may be virus affected and harm the device even more 

 Self Execution of Programs – Files or applications may start opening in the 

background of the system by themselves and you may not even know about them 

 Log out from Accounts – In case of a virus attack, the probability of accounts 

getting hacked increase and password protected sites may also get hacked and you 

might get logged out from all of them 

 Crashing of the Device – In most cases, if the virus spreads in maximum files and 

programs, there are chances that the entire device may crash and stop working 

TYPES OF COMPUTER VIRUS 

Discussed below are the different types of computer viruses: 

 Boot Sector Virus – It is a type of virus that infects the boot sector of floppy disks 

or the Master Boot Record (MBR) of hard disks. The Boot sector comprises all the 
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files which are required to start the Operating system of the computer. The virus 

either overwrites the existing program or copies itself to another part of the disk. 

 Direct Action Virus – When a virus attaches itself directly to a .exe or .com file 

and enters the device while its execution is called a Direct Action Virus. If it gets 

installed in the memory, it keeps itself hidden. It is also known as Non-Resident 

Virus. 

 Resident Virus – A virus which saves itself in the memory of the computer and 

then infects other files and programs when its originating program is no longer 

working. This virus can easily infect other files because it is hidden in the memory 

and is hard to be removed from the system. 

 Multipartite Virus – A virus which can attack both, the boot sector and the 

executable files of an already infected computer is called a multipartite virus. If a 

multipartite virus attacks your system, you are at risk of cyber threat. 

 Overwrite Virus – One of the most harmful viruses, the overwrite virus can 

completely remove the existing program and replace it with the malicious code by 

overwriting it. Gradually it can completely replace the host’s programming code 

with the harmful code. 

 Polymorphic Virus – Spread through spam and infected websites, the polymorphic 

virus are file infectors which are complex and are tough to detect. They create a 

modified or morphed version of the existing program and infect the system and 

retain the original code. 
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 File Infector Virus – As the name suggests, it first infects a single file and then 

later spreads itself to other executable files and programs. The main source of this 

virus are games and word processors. 

 Spacefiller Virus – It is a rare type of virus which fills in the empty spaces of a file 

with viruses. It is known as cavity virus. It will neither affect the size of the file nor 

can be detected easily. 

 Macro Virus – A virus written in the same macro language as used in the software 

program and infects the computer if a word processor file is opened. Mainly the 

source of such viruses is via emails. 

Protect Your Computer from Virus 

The most suitable way of making your computer virus-free is by installing an Anti-

virus software. Such software help in removing the viruses from the device and can be 

installed in a computer via two means: 

 Online download 

 Buying an Anti-virus software and installing it 

Anti-Virus 

An anti-virus is a software which comprises programs or set of programs which can 

detect and remove all the harmful and malicious software from your device. This anti-virus 

software is designed in a manner that they can search through the files in a computer and 

determine the files which are heavy or mildly infected by a virus.  
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Given below is a list of few of the major antivirus software which is most commonly used: 

 Norton Antivirus 

 F-Secure Antivirus 

 Kaspersky Antivirus 

 AVAST Antivirus 

 Comodo Antivirus 

 McAfee Antivirus 

Differences between WWW and Internet 

WWW (World Wide Web) Internet 

The World Wide Web is the common system for 

navigating the internet. It is not the only system that 

can be used for such access, but it is by far the most 

common one. 

The internet is a public network of network 

with a maze of wired and wireless 

connections between separate groups of 

servers computers and countless devices 

from around the world 

The World Wide Web is distinguished from other 

systems through its use of HTTP (Hypertext Transfer 

Protocol). It can be safely said that the HTTP is the 

language of the World Wide Web 

Along with Internters, there also exist the 

Intranets, which is the same type of 

information network but more privatized in 

order to control access. 

WWW is more software-oriented as compared to the 

Internet 

Internet is primarily hardware-based. 

The HTTP along with being the language of the World 

Wide Web also governs it by dealing with linking of 

files, documents and other resources 

The internet is governed by a set of rules and 

regulations collectively known as Internet 

Protocol (IP). The IP deals with data 

transmitted through the internet. 
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The invention of the World Wide Web can be credited 

to Sir Tim Berners Lee. During his work at the 

European Organization for Nuclear Research in 1989, 

he had developed the basic idea of the WWW to merge 

the evolving technologies of computers, data networks 

and hypertext into a powerful and easy to use global 

information system. 

The first workable prototype of the Internet 

was the ARPANET (Advanced Research 

Project Agency Network) in the late 1960s. 

After its adoption on January 1st 1983, 

researchers began to develop a “network of 

networks” which evolved into the modern 

form of the Internet 

Difference Between Internet, Intranet and Extranet 

The major difference between the internet, intranet and extranet is that the internet, 

also known as the world wide web, is a global network of computer networks, and intranet, 

on the other hand, is an internet network that only corporate workers have access to. 

However, the extranet is an extension of the intranet. In this article, we will discuss the 

basic difference between internet, intranet and extranet in the sections below. 

Internet Intranet Extranet 

Internet is open to the 

public, but the other two 

are heavily censored. 

An intranet may be accessed via 

the Internet, although its 

authentication requires logging 

in. 

Extranets are mostly used by 

businesses and organizations to 

limit access to secret 

information. 

It is owned by no one. 
It is owned by a particular 

company/ organization. 

It is owned by single/ multiple 

organizations. 

Everyone who is linked 

has access to it. 

Only members of the 

organization have access to it. 

Only members of the 

organization and external 

members with logins have 

access. 
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Its goal is to provide 

information all across 

the world. 

Its goal is to communicate 

information within the 

company. 

Its goal is to allow members and 

external members to share 

information. 

It is used by the public. 
It is used by employees of the 

organization. 

It is used by the members having 

login information. 

It is more cost-effective 

to utilize. 
It is less cost-effective. It is also less cost-effective. 

 

WEB PAGE 

A document which can be displayed in a web browser such as Firefox, Google 

Chrome, Opera, Microsoft Internet Explorer or Edge, or Apple's Safari. These are also 

often called just "pages." 

WEBSITE 

A collection of web pages which are grouped together and usually connected 

together in various ways. Often called a "web site" or a "site." 

WEB SERVER 

A computer that hosts a website on the Internet. 

SEARCH ENGINE 

A web service that helps you find other web pages, such as Google, Bing, Yahoo, 

or DuckDuckGo. Search engines are normally accessed through a web browser (e.g. you 

can perform search engine searches directly in the address bar of Firefox, Chrome, etc.) or 

through a web page (e.g. bing.com or duckduckgo.com). 

https://www.bing.com/
https://duckduckgo.com/
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Webpage 

  A Web page is a single hypertext document available on World Wide Web 

(WWW). It is composed of HTML elements and displayed on the user's browser such 

as Mozilla, Firefox,  Chrome 

A Webpage is a document written in HTML and can be viewed on any web browser. 

It is contained within the web server, which can be accessed by entering the URL for that 

web page, and once it is loaded, it appears on the user's web browser. Each webpage is 

linked with a unique URL; hence two pages cannot have the same URL. 

 

A Webpage may contain text, links for other pages, graphics, videos, etc. Moreover, it is 

mainly used to provide information to the user in text, images, etc. 

A webpage is a part of a website; it means a website contains different web pages. Such 

as javaTpoint.com is a website, and the page currently you are accessing is the webpage. 

https://www.javatpoint.com/mozilla-firefox
https://www.javatpoint.com/google-chrome
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It can be understood as an example of a book. So, a Website is like a complete book, and 

a webpage is like a page of that book. 

The WWW or Internet contains millions of web pages, and daily, a lot is being added. Tim 

Berners-Lee developed the first webpage. 

Let's understand some basic terms that are used with Webpage: 

 WebSite: A website is a collection of several web pages. These pages are linked 

together with hyperlinks. A website has a unique domain name, and we can access 

it by entering that domain name in the URL. 

 Search Engine: A search engine is an internet service that helps users find any 

information available on the internet. Some examples of search engines are Google, 

Yahoo, Bing, It is usually accessed with the help of Web browser. 

 Web Browser: A web browser or simply browser is application software used to 

access the internet. Some examples of Web browsers are Google Chrome, 

Microsoft Internet Explorer, Safari, etc. It does two things: 

 It connects to a web server on the internet and requests a page that the user wants to 

view; once it finds that page, it displays it on its device. 

 It can interpret the set of HTML tags within a page to display the page in the correct 

format. 
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 Webserver: A web server can be understood as a computer that hosts or provide a 

website on the internet. It contains webserver software and component files of a 

website such as HTML document, images, CSS stylesheet, and JS files. 

 HTML: HTML is an abbreviation of Hyper-Text Markup Language. A markup 

language is a computer language that specifies how a page should be formatted. 

With the help of HTML, one can specify fonts, colors, images, headings, and 

everything that he wants to display on a page displayed by the browser. 

CHARACTERISTICS OF A WEB PAGE 

Following are some characteristics of a Web page: 

 A simple webpage can be created very quickly. 

 It takes very little time to create a webpage compared to a Website. 

 A web page and a website should be compatible with any device, such as Mobile, 

Desktop, Laptop, etc. 

 The search engine provides a web page through a link, and when a user clicks on 

that link, it is redirected to the webpage of a website. 

 A webpage can have any type of information including videos, and audios. 

 It can be made up of only HTML(Hypertext Markup Language), or CSS, or 

JavaScript for dynamic and attractive behavior. 
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DIFFERENCE BETWEEN A WEBPAGE AND A WEBSITE 

Since both Websites and Web pages are related to each other, some users may use 

them interchangeably, but they are much different from each other. The basic difference 

between them is that webpage is a single web document, whereas a Website is a collection 

of different web pages. Here are some more differences between both of them: 

Website Webpage 

A website is a collection of different web 

pages that are linked together with 

hyperlinks. 

A webpage is a single hypertext document. 

It consists of more than one webpage. It is a single document that is displayed on 

the user's browser. 

To develop a website, developers need 

more skills and more time compared to a 

webpage. 

To develop a webpage, developers need 

basic HTML knowledge and less time. 

A website is accessed through its domain 

name, and it does not include any 

extension in the URL. 

A webpage is accessed through a unique 

URL with some extension. 

It can contain information for different 

entities, such as Javatpoint.com, which 

contains information about different 

technologies. 

It can contain information for a single entity, 

such as currently viewing a web page 

containing information about this page only. 

It is a little challenging to create a perfect 

website and requires lots of programming. 

It is very simple to create a webpage. 
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Some examples of the website are 

Javatpoint.com, Amazon.com, etc. 

Some examples of Webpages are the 

currently viewing page, contact page, 

registration page, the home page, etc. 

TYPES OF A WEB PAGE 

There are mainly two types of a Web page based on functionality: 

 Static Webpage 

 Dynamic Webpage 

Static Webpage 

Static webpages are those webpages that cannot be modified or altered by the client. 

These are also known as stationary or flat web pages. They are displayed on the client's 

browser in the same format and manner as they are saved in the webserver. Users can only 

load the page and read the information but cannot perform any change on the page. 

 A static webpage is generally made up of HTML and CSS only. 

Dynamic Webpage 

As the name suggests, Dynamic webpages are dynamic, which means it shows 

different information at different point of time. 

The dynamic webpage shows different content each time it is viewed. There are two types 

of Dynamic web pages, which are: 

 Server-Side Dynamic Webpage: These web pages are created using Server-side 

scripting. These pages are changed when they are visited or viewed. Some examples 
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of server-side pages are login pages, submission forms, shopping carts, etc. 

Various scripting languages such as PHP, ASP.Net, JSP, etc., can be used for 

server-side scripting. 

 Client-side Dynamic Webpage: These web pages are created using Client-side 

scripting. These pages get changed in response to actions that occur within that page, 

such as mouse or keyboard action. Scripting languages such as JavaScript, Dart, 

etc., can be used for client-Side scripting. 

Apart from these two Webpages, there are some examples of common web pages that can 

be found on most of the websites, and these are as follow: 

 Home Page: The home page of any website is one of the most important pages. It 

is called a home page because this is like a starting point from where users can go 

anywhere on that website. This page usually contains links to the important zones 

of the site. It can also be known as the index page. 

 Feed Page: The feed page is usually found in those websites that update content. It 

is used to provide information to users for the latest information that has been 

updated. 

 Menu Page: The menu page is created to accomplish the navigation goal. The page 

contains a collection of different links that give access to different categories and 

zones. 
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 About-us Page: This page contains brief information and details of the company, 

product, or website. It allows the visitors to know the details of the website that they 

are using. 

 Registration Page: The registration page allows users to create an account by 

signing up, and hence they can create a personalized account. It helps the company 

to know the visitor and provide personalized offers and deals to them. 

 Contacts Page: This is a simple page made for the visitors to contact the website 

owner. For any issue or any feedback, users can use this page. 

 Landing Page: This is one of the special types of a Web page used as a core part 

of a website or as an individual page. The main aim of creating this page is to convert 

the visitors into the lead. It represents clear and focused content on a specific goal. 

CREATE A SIMPLE WEBPAGE 

Creating a simple webpage is very easy; anyone with basic knowledge of computers 

and HTML can create it. But before creating a webpage, you should be aware of the below 

points: 

 A simple webpage can be created using HTML code only. Such pages are simple 

but not interactive and have very few functionalities. 

 To make your webpage interactive and add functionality, you need to learn and use 

scripting languages, such as PHP, Python, etc. 

 A web page can also be created using Notepad, but it is recommended to use IDEs 

for advanced uses such as Atom, Sublime Text editor, PyCharm, 
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Follow the below steps to create your webpage: 

1. Open the Notepad application on your computer. 

2. Write Below code on it. 

 

<!DOCTYPE html>   

<html>   

<head>   

<title>Your title goes here</title>   

</head>   

<body bgcolor="white" text="red">   

<h1>first Web page</h1>   

<p>This is my first web page!</p>   

</body>   

</html>   

In the above code, the following tags are used: 

o <!DOCTYPE html>: It is used for document type declaration, which means which 

version of HTML you are using. It indicates the browser that which language it is 

supposed to interpret. 

o <html>: it indicates the start and of the HTML code. 

o <head>: It can have different types of information such as title, meta tag, etc.; this 

information will not appear on the webpage. 

o <body>: This tag contains other tags on the webpage, and users can see them. In 

above code, we have included <h1> heading tag and <p> paragraph tags. 

https://www.javatpoint.com/what-is-a-webpage
https://www.javatpoint.com/what-is-a-webpage
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o Save the file with any name and .html extension. For example, save it 

with html name. 

o Go to the saved file (web.html), double click or right-click and run it. 

o It will open on your default browser and will display the below output: 

 

You can also add more tags for different elements, such as add images, background images, 

border, table, table, etc., using HTML.  

After creating the page, you can also make changes in your file through the editor. Just 

make the change, save the file again, and reload the page; those changes will appear on the 

screen. 
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CREATE AN E-MAIL ACCOUNT 

E-mail is a great way to send and receive information over the Internet. However, 

as there are many different e-mail and webmail clients, the steps used to start an account 

differ. To learn how to create a new e-mail account (and associated e-mail ID) in various 

programs, choose from the list below and follow the instructions. 

Google Gmail                                                      

1. Go to the Gmail website. 

2. At the bottom of the sign in screen, click the  link. 

3. On the account creation screen, fill out all the fields (A) and then 

click Next (B).z 

 

4. On the next screen, fill out your birth date and gender (A) and any other 

information you are comfortable with, then click Next (B). 

https://www.gmail.com/
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5. Read Google's Privacy and Terms, then click the  button. 

6. Click the  button until you've moved through the features menu. 

7. Click the  button, allowing you to access your new 

account. 

Outlook.com (formerly Hotmail) 

1. Open an Internet browser and head to Outlook.com. 

2. Click the  button. 

https://outlook.live.com/owa/
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3. On the next screen, choose a username (A) and a domain (B), and then 

click Next (C). 

 

4. Choose a password, and then click the  button. 

5. Type your name, and then click the  button. 

6. Choose a country, type in your birthdate, and then click 

the  button. 

7. Choose a country code, type in a phone number, and then click 

the  button. 

8. Enter the access code and click the  button. 

9. Navigate through the rest of the prompts and your account is opened. 

 

https://www.computerhope.com/jargon/u/username.htm
https://www.computerhope.com/jargon/d/domain.htm
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Yahoo! Mail 

To access Yahoo! mail, you need to create a Yahoo! account. Here's how. 

1. Navigate to the Yahoo! account sign up page. 

2. Fill out the required fields (A) and then click the Continue (B) button. 

 

 

https://login.yahoo.com/account/create
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3. Click the  button. 

4. Enter the five-digit key, and then click 

the  button. 

5. Click the  button. 

6. Click the  icon. 

Microsoft Outlook 
1. Open Outlook. 

2. In the Add Account Setup window, make sure the circle next to E-mail 

Account is selected. 

3. Fill out the form, and then click the  button. 

4. Once the setup process is done, check the box next to Change account 

settings, and then click the  button. 

5. Click More settings. 

6. Click the Advanced tab. 

7. Next to Root folder path: type Inbox. 

8. Click OK, and then Finish. 

 

https://www.computerhope.com/jargon/o/outlook.htm
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Mozilla Thunderbird 

1. Open Thunderbird. 

2. Click Tools, and then select Account settings from the drop-down 

menu that appears. 

3. Click the circle next to Email account and then click Next. 

4. Enter your name and an e-mail address that you want to use. 

5. Select POP or IMAP for your server. 

6. Enter your e-mail address for the incoming and outgoing user names, and 

then click Next. 

7. Choose an Account Name. 

8. Verify your account information and then click Finish. 

9. Choose an Outgoing server. 

 

 

 

https://www.computerhope.com/jargon/t/thunbird.htm
https://www.computerhope.com/jargon/d/dropdm.htm
https://www.computerhope.com/jargon/d/dropdm.htm
https://www.computerhope.com/jargon/p/pop.htm
https://www.computerhope.com/jargon/i/imap.htm

